Not booting after December update

HI. Happy new year!
Are you sure this new kernel is working for the PI 2?
I tried and retried… I reinstalled the device and it doesn’t work.
Right now I saved my /boot and copied over a backup of /boot without the new kernel and the OSMC is up and running.
Unfortunately I didn’t see an option to access the boot loader and load an old kernel, therefore, having the old kernel installed is pretty much useless.
p.s.: PLEASE NOTE I am not able to provide any log, as the device does not boot at all, it’s not reachable, it’s not pingable, and it looks like the journalctl has a volatile setting (I tried journalctl --boot=-1)

1 Like

Hi Massimiliano,

The new kernel is certainly working for the Pi 2. We always test our builds before releasing them, and we would see many more forum posts if there was a wider issue.

I need to know a bit more about your setup, is it an SD card, NFS or USB installation?

Do you see anything at all when you power up your Pi and it does not boot?

Can you paste your cmdline.txt?



I think I have the same issue.
After the upgrade, the rpi2 restarted and now it’s stuck on osmcfirst screen.

No ssh, no action on keyboard possible…

I’m wondering how I will be able to get out of that.

Any way to do anything if I plug my micro sd card in a Linux laptop to correct the issue? Ortk force the update when you will have corrected the issue?


count me in…

Hi guys,

I am sorry to hear you are having trouble. You will need to follow the advice in my previous post for us to work out what’s going on.

Do you mean you see the blue OSMC splash screen ?

What happens if you press ALT-F2 to try to switch to another virtual console, do you get a login prompt ?

Here are two possible methods to get to an emergency shell where you should be able to capture logs.

Put your SD card in a PC and edit the file cmdline.txt, at the end of the line add a space then:


save the file then try to boot, you should be taken to an emergency console. If that does not work, try again but instead of recovery add:

Assuming you boot to a command prompt, run the following commands to gather logs and save them to the fat partition:

/usr/bin/grab-logs -A -C

Then shut down, put the SD card back in your PC and you should find a file called uploadlog.txt - open this in a text editor and paste it into and provide the link here.


I have just tried the ALT F2, without effect.

I’m on the spash screen… and the only things that tend to prove my RPI2 is not stuck is that I can switch num lock on or off. that’s little…

I tried to open my microsd card in another linux computer and there was an error on the windows partition where vmlinuz is put.(the 255MB one)
No log present on the /var/log directory on the second partition.


See my amended post above to see if you can capture logs.

Systemd doesn’t save plain text logs so you won’t fine traditional /var/log/messages or /var/log/syslog.

If you have a linux machine can you capture the logs at /var/log/apt/term.log and /var/log/apt/history.log and upload them to please ?

Also a full directory listing of the /boot fat32 partition would be helpful, if you’re doing it under linux use ‘ls -al’.

I have exactly the same issue (not booting after Dec update on a RP2, stuck on OSMC Splash Screen). Please find the content of the uploadlogs.txt after the " recovery" addition.

Hope it will help. Some additional details. I use an external usb drive for the content, booting on the SDCard with a USB dongle for remote control.

Thanks. Nothing obvious in the log unfortunately.

Can you try the following:

  1. Can you confirm whether the alternative method of using also works to boot to a command prompt, or does only recovery work ?

  2. Remove the options you added to cmdline.txt and try booting with your external USB devices removed - does that boot ?

  3. Try editing config.txt and add the following line:


If you have a line that says:


then remove it. Does it boot now ?

A post was split to a new topic: Black screen after December update

Please find the wanted results

1- No. If I remove the recovery and replace it with systemd.unit, stuck on OSMC logo again

2- No. Logo OSMC again

3- I had dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18 in my original config file. I replace it with dtoverlay=mmc. But unfortunately, no more luck, still stuck on OSMC logo.

I must say that I had lots of trouble with the tests, not on OSMC side but on my Windows 10 to edit the config.txt or cmdline files. Windows does not stop to complain about that SD has issues and I have to repair it. I did not remember to have so much troubles but I was on Windows 8.1 during last modifications so don’t know if it is an OSMC upgrade effect or a Windows upgrade effect.

Hope that helps a little.


I made additional tests, without the USB Dongle for keyboard: same result. Network seems to be not yet available because I have no SSH access but no ping answer also. I also tried without the Ethernet cable (I am not using Wifi but ethernet).

Sorry to leave you there but near 2AM here and I have to sleep a little before work tomorrow morning :wink: I will take few minutes to check if some additional informations are required in few hours.

Hope to have good news.

Thanks for the support.



I just updated m’y pi and its stock on splash screen (OSMC)

So i have try à fresh install. Trying the update again , samething. Running on a SD card.

I’m getting this issue as well. Updated and can’t get past the boot screen. I reinstalled from noobs and it worked until it updated again. This update is fubar.

Pi 2
SD noobs install
Works until update
No ssh (unallocated ip on router)
No alt-f2

Can you provide more information!
PI 1 or 2?
Install via OSMC Installer or Noobs?
Also please confirm that you can not SSH into OSMC (device not on the network visible)

I’m thinking its not best to do the december update then for a while then judging by the problems being reported

Well it is always better to be save than sorry and there is nothing ultimate that you would gain with the update so waiting should be fine.
On the otherhand it seems to only have impacted a handful of upgrades compared to more than 30,000 successful upgrades.


do you want me to do some additional tests or could I go to the step of the reinstall? If reinstall, is there a way to try before reinstalling with installer?

I must say that I spent some hours to tune everything and if I can just try something to spare me that time, I will try.

Thanks in advance.


I would wait with the reinstall as your system generally seems to be not broken just having a strange booting issue. Unless you need to be up and running in the next hours I think your system is recoverable.