Not even my WORKGROUP is browse-able when trying to add SMB source

Hey Guys,

I just installed OSMC on my Raspberry Pi 2 where I was previously using OpenElec and able to add all my SMB sources from my Windows Server. Now when I try to add any SMB sources there is nothing when trying to browse. I have tried connecting to them server address manually and get an unable to connect. Please help me figure this out. If I need to send logs please let me know how to do so since its not intuitive.

Thanks in advance.


SMBv1 browsing is disabled now unless manually enabled.

OpenELEC is outdated and still ships a vulnerable version of Samba which is why this works out of the box.

This has been covered in some details on the forums.

I was able to add my shared folders via SMB using the add a network location. However I would like to know how to enable SMBv1 on OSMC?

It’s explained in the post that @grahamh posted above