Not recognizing/parsing mp4

Hi.

I can’t get my Vero4k to recognize music mp4’s. I’m on Kubuntu 20.04, sharing nfs, fstab mount in kodi. When I scan for music no mp4’s gets added, but all mp3’s does. They are all in the same directorys. I’ve tried Local information only, Universal audio scraper and the AudioDB. Using SSH to Vero4k and list the content of the shares I can see the files. And if I add the mp4’s to ‘Videos/files’ section, with content set to ‘None’ then they show up and I am able to play them. But they simply refuse to get picked up by the “music scraper” and/or get added to music library. Anyone that can shed some light on this?

Here’s a log:
https://paste.osmc.tv/wagolobuye

Hi,

I believe kodi expects these to be setup as a video source and you need to set the content as Music Video and then scan to library.

Or you could try this (I’ve not tested this):

https://forum.kodi.tv/showthread.php?tid=238208&pid=2101162#pid2101162

Thanks Tom.

Ehm now I am a bit confused, wouldn’t setting the content to Music Videos add them to ‘Music Videos’ section in kodi? The files are only audio. I have Music Videos as well and they are all added fine. The other methjod you linked I am not familiar with. Will look into that. I simply want my mp3’s and mp4s scanned to the ‘Music’ category :slight_smile:

Hi,

This the problem, mp4 is normally a video container; rather than audio. The 2nd option is the one you want, you will need access to the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

you can create the advancedsettings.xml nano

nano /home/osmc/.kodi/userdata/advancedsettings.xml

advancedsettings.xml should look like this:

<advancedsettings version="1.0">
        <musicextensions>
                <add>.mp4</add>
        </musicextensions>`
</advancedsettings>

Alternatively you could remux the mp4s to mp3 or ogg or flac.

Thanks Tom.

1 Like

I see. Thanks Tom! :slight_smile: I will try that and report back.

1 Like

Bumping for attention!

Thanks a lot @Tom_Doyle Your solution worked brilliantly :slight_smile: Now I have all my music scanned :smiley:

1 Like

Changing the file extension to .m4a would probably make more sense then remuxing, although unnecessary with the advancedsettings.xml tweak.

1 Like

Actually that made more sense. Transcoding/re-encoding was never an option since I already ripped my discs, and/or deleted the source files. But mass renaming the extension to m4a was a good idea. Way less headache playing the files in Linux since mp4s kept wanting to be handled by VLC instead of Elisa. And Kodi handles them well.

2 Likes