November update went wrong

Hello. I have a problem. The november update didn’t go well. I can no longer enter My OSMC to search for updates. The OSMC is working but I thought it’s time to try to make it right. It seemed like the update went well but, as stated, I can no longer access My OSMC. Does anyone have a solution? I have never used sudi, Last time I Had a problem I got a code to Enter.

SSH into your vero and run the following commands

sudo apt-get update
sudo apt-get dist-upgrade

If that does not rectify the situation please run the following and post the url it returns in this thread.

grab-logs -A

Thanks for the quick reply. Working night shift so will look it Up when In wake Up.

The TV went black screen, it seems like it worked, but what do I do now with the black screen?

After the updates finish installing you can issue the following command at the terminal…


Thanks, it worked great!

So manually updating from the command line got everything working again and we can mark this as solved?

Yes, exactly.

1 Like

This is intentional: when performing command line upgrades, we won’t automatically restart Kodi.

Alright, now I know. Thanks to both of you so much for an excellent product and even better Help!

Forgot to mention but you can start Kodi by running systemctl start mediacenter after the upgrade option.

1 Like