Novice trying to set a Fixed IP for WiFi

Continuing the discussion from Unable to set static ip for wlan0:

I have 2 RasberryPi running OSMC.
I also use Playon installed on a PC
Each time I try and access playon, it cannot locate the files, and I get an error message about check the log… wouldnt have a clue where or how to do this.

If I redo the settings it will often work.
I think this all relates to dynamic IP address es changing

I have tried allocating fixed IP addresses for the 2 RasbeeryPi running OSMC.first on my Router/Modem, and then trying to work through the cryptic settings in OSMC.
there seems to be a manual or DHCP setting… but trying to qork out whether it is on Manual or DHCP… is anyones guess. you click it and it toggles…
the question is - when is it on manual??

Since I have ve been trying to this…
The one Rasberry PI boots into OSMC, takes ages, and will not connect, I can also no longer get in to change the Wifi at all. I get an option to connect to my modem, it takes ages and does not connect.

Is there any step by step simple instruction to follow

I am wanting to access Playon on my PC each time without having to waste time searching and changing IP addresses.

Hope some one can help…


It’s on Manual if it offers you the chance to configure via DHCP.

Thanks for That…

If it was a snake it would have bit me
I have managed to set one of my units up with a Fixed IP, and it appears to be working just fine.

My second unit will not let me do any editing of the WiFi settings…
It takes ages to startup,OSMC and when trying to modify the wifi settings I only have a connect options which takes ages and fails.

What is the best way to delete the wifi connection or reset it?

Thanks again

I know little about the wifi settings, as all my installs have been wired for some time. I think that they used to be in guisettings.xml

Thanks for that.

Initially I was able to make changes to my WiFi connection in the GUI.
For some reason I cannot do that anymore… very strange.
Theonly option I have in the GUI is to select connect… which fails or takes ages and then fails.
I cannot select DHCP or Manual,

Appreciate your comments


To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Hi Thanks for offering assistance.
I fiddled around a bit in the GUI, and managed to change the IP Address to the static address I setup (for some reason it had a totally weird ip address - whichis why I couldnt connect??)
Anyway I am now back on the Internet.

I tried to do a manual update from the OSMC program,
I get the message
ADD ON ERROR Check Log for details
Each time I try and update I get this message…

Hoping you can point me in the right direction.

Thanks in advance

Hi there

just to add, everything was working fine until I tried to setup static IP’s in the WIFI.


Hi i have just uploaded the logs as per the instructions