"Now playing" song title and artist info when playing audio

#1

Hey all,

i tried to search this topic but didnt really find anything useful. I do understand that this is RC2 and work is ongoing with the skin but wanted to add some of my own toughts.

I use most of the time Airplay. The problem is when a audio file is playing i dont see really any information about it. I think it would be great to have the song title and artist on the bottom row visible at all times. And a “now playing” window like some skins have.

I’v built my raspberry with OSMC in my car and really love the skin and everything, It works better than anything i’v tried so far. (Openelec and so on)
My only problem right now is that when a song is playing i have to watch just the menu and thats it. And to be honest those visualization things look just hidious :smiley:
Maybe something similar like the box theme has, where it shows artwork and song title and so on.

Just wanted to let you know and hope you are dealing with this also because i didnt see anyone else mentioning it.

I dont know if its hard to implement, i think this has been discussed several times in openelec forums also but it would be great if there would be an option to increaze font size. At the moment its running in my car and the resolution isnt very good there so bigger fonts would be helpful.

#2

Press back enough times and you’ll open up the visualiser.

#3

Yeah i noticed that. But as i was saying the visualizer is ugly and i disabled it. So when i press back i get a dialog box at the bottom where is the artist and song title with a black backround and after a few seconds the box will dissapear and a black screen remains ( thats where a viusalizer should be playing - but againt o be clear, its ugly :smiley: )

#4

I have the same question. In Kodi, we can use the left menu and there is a toggle fullscreen button to use. However, the button is removed along with a few controls in the menu of OSMC.

I have found a workaround which is working well for me. Without getting into details, it’s basically use the official Keymap Editor to edit the key “Music” - “Playback” - “Toggle Fullscreen” to whatever button convenient to you. For me, I use the left button on my remote.

Maybe you also want the song info to stay on screen longer. Then you need to add a line in advancedsettings.xml. See songinfoduration However, I tried “Indefinite (0)” which did not work so I put 1000.

Hope this helps. :smiley:

#5

If you want the song info to stay in fullscreen music playback, you just have to press the info key once the information has disappeared. It should stay visible forever from then on :wink: No need to adjust anything…

#6

I don’t know where the info key is. I have tried every button on my TV remote. Nothing works as the info key. My TV supports HDMI CEC.

#7

I guess its the i on the vero 4k remote if you don’t have a vero I guess you’d have to map it to a key on which ever remote you have

#8

I don’t, so I use the workaround. There is no info key in Kodi Keymap Editor. At least, I don’t see it.

#9

Just connect a keyboard and press the i button :wink:

#10

We can then all go back to vinyl. Info is on the cover. :thinking:

#16

Your modern times TV CEC remote doesn’t have an info key that’s passed on… :wink:

Another option is a Kodi remote app that offers an info key.
Will have a look at the keymap editor later. The info key should be configurable there. :slightly_smiling_face:

#18





1 Like
#25

I tried, but it did not work. Thanks anyway.
I also tried, “Global” - “Navigation” - “Show Info”. Neither did it.

#26

Did it actually show the keymap changing when you pushed the button on your remote? CEC normally only passes a small number of keys to any device it is connected to. Often for a player it does not extend out much past the direction, menu, and playing keys. You might have to just keep trying different buttons till you find one that is being transmitted over the CEC. Just make sure you don’t set it to a button that you want to keep using in the section your editing.

#27

Yes. I used one of the few working keys. If you read my workaround, “Left” button is working.