NPVR Schedules Direct EPG Not Showing Correct Information

Hi all,

I recently had to rescan my OTA channels due to spectrum repacking. I went through the process in NPVR on my Windows 10 “server” then validated that all was well when watching TV through NPVR. All channels showed up in the EPG (I use Schedules Direct) with correct information about the programming and all channel logos displayed correctly. (One logo changed.)

I also have Kodi Leia running on the server that’s running NPVR. I started it and confirmed that all was well within Kodi, too. All channels showed up in the EPG, all programming information appeared correct, and the channel logo that had changed was displaying correctly.

Then I fired up OSMC and rebooted it to ensure (I thought) it was getting the latest information from the server. Evidently it was not. One channel is not showing in the “Guide” display, but all of them are showing in the “Channels” display. Moreover, some programming information is incorrect in the Channels display. Finally, OSMC was not picking up the correct channel logos from the server. In particular, one in particular that had changed continued to show the “old” logo for that channel.

In case it’s relevant, if I try to tune to the channel that is showing in the Channels display but not in the Guide display, it takes considerable time, with significant buffering. Eventually, it does tune to the channel.

Until this rescan, I had no trouble with Guide and related data, and virtually no buffering tuning to and watching live TV.

My logs are here:

Thanks very much for any help.

Hi – you might need to take this up with the NextPVR maintainer.
You could also try disabling the add-on; re-booting and re-enabling.

I can think of a hammer like fix, but don’t know where channel logs etc are cached for a more localised approach.


Thanks for the quick response, Sam. I tried your suggestion: disable the addon, rebooting, and re-enabling, but no joy.

I’ll head over to the NPVR forum and will report back if I learn anything.

The nuclear option would be to remove your ~/.kodi data.

You could check addon_data for nextpvr and try removing that (would probably do the trick).


The folks over on NPVR had the answer immediately. There is a “Clear Data” button I needed to click to force the new guide and channel data to load in OSMC. In OSMC, that button is here: Settings > LiveTV > General > Clear Data

It remains to force OSMC to load the correct icons. To do that I need to delete the icons in this folder: ./userdata/addon_data/pvr.nextpvr Do I need to jump onto the Linux command line to do that?

Incidentally, I think the performance/buffering issue is a red herring. I’ll keep an eye on that and raise an issue if it becomes a problem

Thanks for the help.

Yes — that would need to be done via the command line.

There is advice on how to do that in the Wiki.

Thanks Sam. I’ll look that up.

Sorry to come back on this.

As I was preparing to figure out how to delete the png files from the pvr.nextpvr directory, I was looking into using Windows 10 powershell rather than installing PuTTY on my new laptop. Then I decided to access my RPi using Windows File Explorer. I did that and easily navigated to the appropriate directory containing the png files on the RPi.

Can I simply delete the logo files from Windows Explorer? I know I could just try, but before I do, I thought I’d check here before I did something that goofs things up.

Thanks for any help.

I don’t know how they are stored. I would ask the maintainer of the add-on.