NTP / time server to set time


I’m just wondering how to set OSMC to use NTP to set the PI time and date correctly.
Looking through the many settings I did not find a point where I can set time and date manually.
To be honest: Using an NTP server would be the best. Otherwise the time is always wrongs after booting.

Is there a way to configure NTP and a time server in OSMC ?

It already does this(use a NTP server online), it have to because RPI have no realtimeclock…

it you have any problems with the time on it, be sure you have set your localization(timezone)… and then it just requier that it’s oneline…

if there is no network avalable, it will use fakeclock(last one saved as file)…

There is already an ntp server/client installed by default on OSMC as the Pi has no hardware clock.

If your time is incorrect it means that your internet connection is blocking source or destination port 123 so that the ntp client can’t connect to any time servers. (It uses the standard debian time server pool, see /etc/ntp.conf)

It sounds like you have not run updates recently either as a couple of weeks ago we added an additional backup method of setting the time on boot using an HTTP request - this will allow the time to be set correctly (well, within a couple of seconds) on boot for those people whose internet connection blocks port 123, however it won’t maintain continuous time sync like ntp will. (ntp will make frequent small corrections, the http workaround sets the time only during boot)

I would suggest that you run an update and you should find your time is then set correctly using the http backup method. If it’s still not working then you need to troubleshoot your connection to the internet to find why it can’t connect.

Thank you.

The solution was indeed the incorrect time zone. When I checked the time I did not realize that it was just a wrong time zone.
The only difficulty was to locate the menu settings to adjust the time zone: This must be done under settings -> skins.