Occasional resolution drop issue

Hi all,

I’m running two Vero 4K units, one on my Panasonic OLED (TX-55FZ952) and one on my projector (Epson EH-TW9300), and I am seeing an occasional “hiccup” in the output resolution from both.

These are separate setups in different rooms (hence the use of two Vero units) and are totally independent from each other, with the exception of a shared MySQL database which is hosted on my NAS.

When a video finishes and Kodi returns to the library screen, the resolution drops from 1920x1080p/23.98 to 720x740p/59.94. For example, tonight I watched an episode of 24 on my projector which displayed correctly at 1080p, but as Kodi dropped back to the episode list, the interface reverted to 480p. If I then play the next episode, it is clearly displayed at the lower resolution.

If I check the settings in Kodi, it still states the output is 1920x1080p/23.98 but the projector reports it is receiving a 720x480p/59.94 signal. I remember this happening with Kodi version 18+, but not with version 17.

I have taken a photo of this and can upload any log files or output from the terminal.

So far the two workarounds I have used as a temporary solution are:

  • Reboot Vero 4K
  • Switch to any other resolution in settings, then switch back to 1080p/23.98

One Vero 4K is connected directly to the OLED TV. The other is connected to my projector via my Denon AVR-X4200W receiver but I don’t think that is the cause of the issue as I have it set to simply pass through the video signal, i.e. it doesn’t do any scaling.

This has worked flawlessly previously, and does work 99% of the time now. I just see the occasional drop to lower resolution since (I think) Kodi 18.

Any ideas on what could be causing this, and a possible fix? I’m familiar with SSH so happy to help test.

That would be a good start. Just upload debug logs after it happens.

I ran into this as well, after trying to play a Twitch stream (which fails currently due to API issues) but after the Kodi UI popped back up I was in the ‘low rez’ mode and had to reboot. Vero 4k+ -> Pioneer AVR -> LG OLED

Is there any way to enable debug logs without the telemetry showing in the top left of the image? I don’t really want to watch a whole episode of 24 with that in the top corner, on the off chance that this issue will crop up. If I could leave it going in the background (i.e. not visible) it would be a lot better.

You can make (or edit) an advancedsettings.xml file with the following…

<advancedsettings version="1.0">

Once you are done troubleshooting you will want to remove that command.

Thanks, I have set that up. I’ll report back to this thread with a log file next time I see the issue.

1 Like

Here is my log file:


I searched for “480p60” and can see there are several entries in there. Hopefully it will shed some light on the issue!


Something’s wrong - because when your logs were uploaded, we couldn’t determine any supported video modes.

====================== Display Cap =================== g0gjk991

---------------------- Display Cap END --------------- g0gjk991

When you uploaded the logs, were your AVR and display on?

How long is the cable run to the projector?


Ah. No, Vero 4K was rebooted when the AVR and projector were off.

I was at work so I just SSH into the Vero over VPN and pulled the log from it.

I’ll post another log when I’ve captured it locally with the AVR and projector switched on.


Thinking about it, could the problem be that I reboot while the AVR / projector are off? I usually do this from work (SHH over VPN) if there has been an update to OSMC.

If this is the case, is there a way I can generate a list of the applicable video modes then apply this as default on startup, to prevent the issue in future?

I rebooted via the Kodi interface last night as I was experiencing a different issue (blown out blacks, as if the brightness had been turned up) which fixed it and I didn’t see the drop to 480p/60 after that.

Yes – that would be problematic.

When your equipment is on, run:

sudo cp /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/disp_cap



Hi Sam, been looking into this for myself as well.

Just wanting to confirm if the location supposed to be:

sudo cp /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/disp_cap


sudo cp /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/userdata/disp_cap

Sorry - missed userdata, that is indeed needed.

OK I have copied the “disp_cap” file as instructed. I assume this is EDID information captured by the Vero and copying it to the userdata folder forces Kodi to use that config on boot up; is this correct?

Can you tell me what the “*” means? My file looks like this:


I assume that means Kodi will fall back to 1080p/60Hz as a default if it needs to.

Is it OK to change this to 1080p/24Hz by editing the file? I have my projector set to 24p for menus because most of my media is 24Hz and switching between 24/60 takes a few seconds on a projector.


The * is what the TV/projector is advertising as its preferred mode if I remember correctly.

1 Like

Ah, that makes sense. I assume OSMC just reads from this file and falls back to the preferred mode if it doesn’t receive any other information. In my case it was falling back to 480p/60 because this file wasn’t in place.

I will amend it to 1080p/24 (does this imply 23.98 / 23.976 as well?) and see if this fixes the resolution drop issue.

Well I haven’t seen the resolution drop issue in over 10 days now so it looks like this issue is resolved.

Many thanks for your help!

1 Like