Occasionally video stutter / does an increase of video buffer help?

Good morning forum,

I observed that playing some of my BR rips (mkv, 1920x1080) generates occasionally video stutter: video stops playing, but sound continues for 2 to 3 seconds and then video and audio is sync again.

My Vero 4k+ is connected via LAN (gigabit LAN) to my nas (Windows) and the shares are configured using autofs. No problems here.

I am not sure if this symptom is related to the video buffer or if these av asyncs are ripping errors.

Would you guys recommend to generate an advancedsettings.xml to increase the video buffer? If so, what would be a good buffersize?

On the other side I would like to check my mkv files for errors. Is there a specific program to check a video file for stream errors?

Thank you for your kind help.



First thing you can do is to provide logs so we can check your settings.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

If that is the case a buffer increase wouldn’t change anything. Did you check your network speed with iperf3 to ensure you get gigabit speed in both directions.

Thank you fzinken, here is the result of my iperf3 check:

osmc@osmc:~$ iperf3 -c192.168.179.29
Connecting to host, port 5201
[ 4] local port 59551 connected to port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 103 MBytes 863 Mbits/sec 0 269 KBytes
[ 4] 1.00-2.00 sec 110 MBytes 920 Mbits/sec 0 271 KBytes
[ 4] 2.00-3.00 sec 111 MBytes 930 Mbits/sec 0 271 KBytes
[ 4] 3.00-4.00 sec 111 MBytes 931 Mbits/sec 0 271 KBytes
[ 4] 4.00-5.00 sec 111 MBytes 931 Mbits/sec 0 271 KBytes
[ 4] 5.00-6.00 sec 111 MBytes 931 Mbits/sec 0 271 KBytes
[ 4] 6.00-7.01 sec 110 MBytes 918 Mbits/sec 0 272 KBytes
[ 4] 7.01-8.00 sec 112 MBytes 941 Mbits/sec 0 272 KBytes
[ 4] 8.00-9.00 sec 111 MBytes 931 Mbits/sec 0 272 KBytes
[ 4] 9.00-10.00 sec 111 MBytes 930 Mbits/sec 0 272 KBytes

[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 1.07 GBytes 923 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 1.07 GBytes 922 Mbits/sec receiver

I think that i do not have a problem with my network speed. Best guess is the the video stream is corrupt.

I have not found a program jet to check the mkv for stream errors.

Thank you


Looks good, how about reserve direction -R

mkv is only the container so the errors are most likely in the video stream (which depends on the used codec).
You could run it through ffmpeg to see if it throws out errors but that could be quite time consuming.

Thank you very much for your hints and clues.

Checking a video stream for errors with ffmpeg is indeed a time consuming thing. I used the program makemkv to generate mkv files from my iso. Makemkv reported some av async errors while writing the files in the mkv container.
So my issue is solved, the occasionally stutter are results from the av sync errors.

That’s normally not an issue with MakeMKV, it’s just warning you that it’s fixing problems on the original disc. I see this on lots of discs that I rip and have never noticed it causing stuttering in the mkv.

So either it’s a really bad disc that MakeMKV was unable to fix or you have another problem.

I’m getting similar problems with material which were working before last update.
HD material (720p) play fine, 1080p stuttering. No change was done with the HW.
Log file uploaded: https://paste.osmc.tv/weduhilije
Vero 4K+ connected to NAS via NFSv4.
Open Source Media Center 2023.07-1 (kernel: Linux 4.9.269-32-osmc)
Kodi 20.2 2023-07-24
Same material, same file on NAS, working with Kodi on Mac via WLAN.

You responded to a 3 year old thread that is already marked as solved.
so besides opening a new thread my first suggestion is also to test playing the same file from local storage or USB to exclude the Network as source of the problem.

thanks for jumping in anyway,.
There are many similar threads, so why not just choose a similar subject to not populate the forum with a lot of similars :wink:
However I tried copying a 1080p movie file to the device itself: same stuttering behavior.
The log file should give enough hints. Reading several similar threads, I noticed, the update might be the reason.
I’m using files already played successfully in the past, with the same HW setup.
If a new thread is mandatory, I’ll create one.

Hard to tell because of so much logspam, but you are not using HW acceleration for playback. This would indeed result in stutter.

I read several threads, just to be sure don’t to miss a known issue, it seems I have inadvertently unchecked this :frowning: Well, that’s it, thanks.