Oct update and 10 bit movies


#1

I have been forcing 444,10bit mode via rc local for sometime now.

I have added a # to rc local now so it doesn’t force 444,10bit.

Playing hdr movies doesn’t switch the vero into 10 bit mode like i expected it too. Hdr does trigger correctly however.

I’m using a lg b7 connected vero via soundbar.

Anyone else experiencing this?


#2

Make sure adjust refresh rate is enabled and GUI resolution is set to 1080p.


#3

How do you know it’s not 10-bit? 4k24Hz movies may play at 422 which many AVRs will report as 8-bit or not show a bitdepth at all. cat /sys/class/amhdmitx/amhdmitx0/config will show you what vero is sending to your screen.


#4

Hi Graham

Yes that’s the command i was using.
I have two Vero4k’s, one works fine, switches to 10bit the other does not. Both TV’s are lg b7’s.

One thats works fine is connected via a samsung soundbar:
@osmccinemaroom:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

One that doesn’t, is connected via a Cambridge Audio soundbar.
osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 8-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off


#5

Here are some logs:

https://paste.osmc.tv/axehaseyel


#6

It seems the Cambridge Audio is not passing on deep colour support to vero. You will have to continue forcing 10-bit in rc.local:

echo 10bit > /sys/class/amhdmitx/amhdmitx0/attr


#7

Thanks Graham I tried it but doesn’t seem to work.

If I run the command
sudo watch cat/sys/class/amhdmitx/amhdmitx0/attr
it reports 10 bit however if I run
cat /sys/class/amhdmitx/amhdmitx0/config
it reports 8 bit.

Playing opening scene in black panther confirms that it isn’t working as I see banding.

I am certain this all worked before prior to Oct update, as I tested it all when I edited the rc local file and used black panther as my test movie.


#8

It ought to override. We’ll check it out.


#9

I checked my cables to be sure it’s not them. Confirmed cables are fine as works when connected directly to TV.

Would you consider adding a force 10 bit mode to settings menu?


#10

Hi Graham, have you had a chance to look into this problem yet?


#11

Tonight’s build may do the trick

Sam


#12

IIRC echo 10bitnow | /sys/class/amhdmitx/amhdmitx0/attr should just give a warning in dmesg but not actually downgrade to 8 bits. Similarly the rc.local dodge should do the same.

I’ll check it again tomorrow when I’m sober.


#15

Apologies. We are forcing 8 bits if there is no deep colour support atm. That will be changed in the next testing release. You will then be able to use echo 10bit > /sys/class/amhdmitx/amhmitx0/attr in rc.local to force 10 bits through your CA soundbar. CA really should sort this out, though.


#16

Thanks Graham. Is it easy to update to a testing release and then go back to the official updates?

Unfortunately I do not think CA will fix this issue via firmware update as sound bar isn’t connected to the Internet. No WiFi or ethernet.


#17

Yes, but Sam hasn’t rebuilt the kernel with that change in it yet. We’ll let you know when it’s ready.

Not even a USB socket for upgrades?

Edit: workaround for now would be plug vero into your TV direct and
cp /sys/class/amhdmitx/amhdmitx0/disp_cap ~/.kodi/userdata
Plug vero back into soundbar and Power->Exit to restart Kodi


#18

I can wait until the new kernel.

I’ll double check the USB, but there is a note on their support website that says they can’t be updated.

I imagine I would need to get a refund from the retailer and class it as faulty. Rather not go to all that hassle.


#19

Graham please could you explain what this workaround does?

To me it appears to copy display capabilities from tv to override the soundbar, is that correct?

If so why would it work as the display capabilities seem to show resolution only and not if display is capable of 10 bit?

Should i do it for edid instead? I can see in that the CA soundbar the result for a line in the results says:
ColorDeepSupport 0x80 10/12/16/Y444 0/0/0/0

But for my Samsung sb, and when connected directly to the TV it says:
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1


#20

The new kernel is available. You can test as follows.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

It may take an hour for these changes to reach your local mirror.

Cheers

Sam


#21

I think you’re right - it doesn’t work. Ignore and grab the new kernel.


#22

Hi Sam and Graham

Sorry for the late reply. I followed the instructions and i can confirm it now outputs 10 bit. Black panther shows no banding. Thanks for resolving this.

I have not edited the RC local, as it is working fine without. Is that expected?

Should i remain on this now or revert changes and wait for the official update?