October Update 17.5 fails to boot

Hi. Just installed the latest update and all the update procedure went well. But after restart my Pi B ends up with an empty black screen. Blue startup screen with osmc logo is shown but then just black. Can´t ssh either. Was set up with NOOBS if that matters.

As this is not my first experience like that with osmc I guess that (again) I can´t do anything than a fresh install right?!

It´s now the third time that osmc just hangs on start (different errors though) from one day to another. Had libreelec running for a while without that kind of problems. I just can´t imagine it´s osmcs´ fault so any ideas on how to troubleshoot for the future as I want to continue using osmc also with my newly ordered Pi 3.

Thx and greetings

Such problems are usually down to issues with the SD card. If you have a spare SD card, do a fresh install to it - and don’t use NOOBS, since it introduces potential issues such as small partitions. If no spare card is available, you’ll need to overwrite the card, but it might already be failing, so it’s a risk.

Suuper strange now!

Did a third restart and tried to ssh with no success. Did a fourth restart and tried to ssh right at when start screen shows and BEFORE black screens occured. It worked. I just types “ls” a coupple of times to see if it will hang and whoop - osmc is working again! o.O

I don´t know, but for me this is unexplainable…

There will be a reason. See if you can successfully reboot OSMC.

My money is still on an iffy card, but it might simply be a file corruption.

Ok. So I really don´t know what is going on. osmc run fine yesterday and just to prove it i did a restart again and again it ends up stuck with a black screen.

How to troubleshoot this?


How are you connecting toy network? Wired or Wireless.

If wireless, can you connect wired so you can upload logs?

Thanks Tom.


After restart again I connected ssh when boot screen shows and osmc seemed to stuck again on black screen. Then I powered my pioneer receiver on (before it was in standby which passes the hdmi signal through, too) and osmc was shown then. BUT I tried that yesterday too, and it didn´t work. So maybe it´s a combination of my receiver/tv setup that sometimes brakes osmc?? o.O

Don´t know but I also have that “bug” that controlling with my tv remote sometimes doen´t get recognized or a button press is registered twice by kodi. I think this is because of the slow pi b?