October Update broke My OSMC and YouTube addons

After the October Update I’m no longer able to launch My OSMC and YouTube addons on my Raspberry Pi 3 Model B.
I get the following error messages everytime I boot into OSMC.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Here is the link: uploaded log file

1 Like

The log shows a few python-related errors that might be related yo your problem, so a good first step would be to reinstall the python packages that were part of the last update.

sudo apt-get update
sudo apt-get install --reinstall python-2.7 libpython2.7 libpython2.7-stdlib python2.7-minimal libpython2.7-minimal

and then reboot.

1 Like

Thanks, let me give it a try.

Thanks, it worked!

After running the second command I got an error:

E: Unable to locate package python-2.7
E: Couldn’t find any package by glob ‘python-2.7’
E: Couldn’t find any package by regex ‘python-2.7’
E: Unable to locate package libpython-2.7
E: Couldn’t find any package by glob ‘libpython-2.7’
E: Couldn’t find any package by regex ‘libpython-2.7’

So I had to leave those packages and run:

sudo apt-get install --reinstall libpython2.7-stdlib python2.7-minimal libpython2.7-minimal

And after a reboot my system worked as expected, I can now launch MyOSMC and other add ons.

Good to know you’ve got everything working again. But from the errors that you had I’d suggest that you get a new SD card as your current one may be failing.

Okay. I’ll definitely do that , thanks

This code worked well:

sudo apt-get install --reinstall python2.7 libpython2.7 libpython2.7-stdlib python2.7-minimal libpython2.7-minimal