October update fails on Vero1

I recently ran the October update for my Vero1 but it failed with a message saying “an error occurred installing the following package vero1-device-osmc”
The system then rebooted but failed to restart. After trying a number of fixes I gave up an reinstalled the 2018 image using the install tool. This worked fine but when I tried to run the latest updates I ended up back where I started with the original failed to install message.

Any suggestions? It’s the latest update safe for the Vero1?

Different Story.
Please create new thread and provide logs.

Two possible issues come to mind:

  1. Have you been on 4.9 Kernel Testing?
  2. Had you been using RetroOSMC?

Vero 1 support ended some time ago.
The last compatible image is from December 2018.


Ok, thanks Sam. Is it possible to get the image from earlier this year? It’s being running fine on that.

There isn’t an image that has been produced this year, or 2019.

When did VERO 1 come out ?

Judging from this post Nov 2014.


1 Like

The first units shipped in March 2015.

Raspberry Pi-1 came out 2012 and still supported I have been dragging my feet on purchasing VERO 4K

Raspberry Pi 0/1 support will end when Kodi v19 is released.