October Update Will Not Play 10bit Movies As 10bit

I had been on the August update which had the manual HDR auto-switch option. With that option activated, when I played a dozen .mkv movies, nine of them would play at 10bit. The others played at 8bit. I would back out of what was playing at 8bit, go to one I had just played previously at 10bit and start playing it. Stoped it and start playing the previous movie that had played at 8bit, which now plays at 10bit. Also occasionally, a few seconds after starting to play a movie, the screen would go black and a few seconds later I would get a blue screen. Pressing stop & return on the remote got me back to the list of movies and I would start playing the same one and it would play ok. A bit frustrating but a 10bit would play in the end.

Was so looking forward to the October update.

I have the auto update disabled, so I manually backed up the Vero4K onto a USB stick through the option to do so within OSMC. I then updated through the Vero4K options to the October update.

I tried playing those dozen movies again and every one of them plays at 8bit. I rebooted, no difference. I switched off through the menu, remove the power plug for two minutes & turned on again. The same result, no 10bit .mkv will play at 10bit, only at 8bit.

I decided to go back to the August update. When I chose the option to load it off the USB stick I had just saved it to, it started but then gave a message about not all files could be loaded (or words to that effect). I found that I was stuck on the October update.

I downloaded the August update onto another USB stick and am now back to running it on the Vero 4K. I configured it exactly as I have had it configured for months, making sure the auto switching of HDR was enabled.

I can now play those dozen movies at 10bit. Those that, at first play at 8bit, I just do what I have described in my first paragraph and they play at 10bit.

As to why I could not restore the August backup from the backup I had done 30 minutes prior, is a puzzle that is of less importance to me, as the lack of 10bit playback on the October update takes precedence. I am quite happy to download a previous version from the website.

So, any idea why my 10bit will not play as such?

We would need a log to see what’s going on here. We made testing available for almost two months and received positive feedback on this matter.

What equipment are you using?
How are you checking 8 vs 10-bit output?

I’ve never seen this issue. Can you elaborate? I suspect you tried to restore a backup via My OSMC. This doesn’t change the OSMC version and you need to reinstall via Download - OSMC to perform a downgrade.

Onkyo TX-RZ810/Samsung JS9000 TV

On the Onkyo, I can bring up a display that will show what the audio & video input it is receiving, once a movie has started to play.

You are quite right, I tried to restore a backup vis OSMC. I did not know that I could not. I did the downgrade from that link.

Not having used the “logs” option before, can you tell me what Logs you want and a link to how to take & upload Logs?

It will take me a while before I would be ready to submit the Logs.

Thank you for the information. This is helpful.

What would be handy is if you can go to Settings -> Logging and enable Debug Logs. Play content that you expect to be played as 10-bit. Verify that it isn’t.

Then go to My OSMC -> Logs, upload all Logs and let us know the URL. We’ll then take it from there.


I have updated to the October release. Here is a bit more info to scratch your head about.
As before, the 10bit movies report as 8bit.

Now here is the weird bit… I have played a few 1080p .mkv movies and also some 1080p episodes of Game Of Thrones and my Onkyo are reporting all the 1080p as 10bit. lol.

To be precise, my Onkyo has never actually displayed 8bit or 10bit. Instead, it has reported 1080p (8bit) as 24bit and 2160p 10bit as 30bit. Why? I have no idea. But, I came to the conclusion that 24bit is 3x8bit and 30bit is 3x10bit. Hence, 24bit is actually 8bit and 30bit is actually 10bit.

Moving on from the 24/8 and 30/10 reporting, it looks like the bit reporting is in reverse. i.e 8bit is reported as 10bit and vice versa.

Does that info help with what is happening? I would think that it is a clue to the problem.

There is another member of the forum (Theetjuh) who has a TX-RZ820 and I wonder if he will experience the same symptoms?

@theoldfarter Mhhh, but do you mistaken the displayed numbers 24/30 with bit depth instead fps (frames per seconds)?
I’m quite sure these numbers do not relate to the bit depth but consult the manual of your AVR, please. :wink:

You can also check with the mediainfo output of your video material with the the frame rate correlates to the displayed numbers 24 and 30.

They do, they are used for bitdepth.
It actually works like @theoldfarter says, but like wesk05 has mentioned before, not all hardware can see the difference between 8bit and 10bit well.
So this can mean your AVR says 24bit, but it is actually a 10bit stream.

I haven’t updated to October yet, but will probably do this tonight.

Mmmhh, from the Onkyo manual:


In the example it’s clear the second number of “1080p/60” is the frame rate or is there any 20bit standard defined following your interpretation?
Why you think you see something like a constructed bit depth 3 x 8=24 or 3 x 10=30 if you now play 10bit material? Can’t that be that it is still the frame rate you see?

The family are watching TV at the moment so I will have to wait until they have gone to bed before I can get back on the Vero4K. One thing I will do is play a 2160p movie that I, and others on the forum, have had problems with banding. That movie is Dunkirk 2017. There is a particular scene just before the beach getting strafed by a German fighter plane, that shows bad banding when being played in 8bit and the banding disappears when playing in 10bit mode.

If there is no banding then the movie will be displayed correctly & the Vero4K is doing its job. As for why the 8/24 and/or 10/30 is being shown, that will need more info and logs may show something.

One thing I don’t understand as to why a 1080p movie shows in my display window as 30bit when it has never, I repeat never, been displayed like that. They have always shown as 24bit. If the numbers are the fps (frame rate) then they should report the same on each update. After all, isn’t the fps hardcoded into the movie?

I will wait for Theetjuh to update and report back on what he finds. Hopefully, he will also play a 1080p file to see what it reports.

1 Like

Dunkirk 2017 & Blade Runner 2049 are playing correctly with no banding. The reported bit rate problem hopefully will be solved at some time. It may be just the Onkyo that is affected. I will wait to see if others report the difference in what rates are showing for their 2160p & 1080p.

Sam, do you still need logs?

An update:
I discovered that I had the Onkyo HDMI Sub out (zone 2) activated. I have a 4K Samsung 43 inch in my bedroom and use an amplified 18 metre HDMI cable under the house to connect the lounge Onkyo to the bedroom TV. With the zone 2 switched off, 2160p movies now show as 30bit (10bit), instead of the 24bit (8bit) as before. I would say that 10bit files are playing correctly.

1080p movies still report as 30bit (10bit) and terrestrial TV (digital) shows as 36bit. I am not knowledgeable enough to know what that means.

I will not get lost in what is being reported by my Onkyo as visually, it is great. So is the audio.
If an explanation can be found and it fixed, that would be good.

Found that page in the manual. What the page does not say is that if you hold down the info button on the receiver when it is displaying “1080p/60”, more info is shown after that. The info that is then displayed is, now that I have disabled zone 2, is “YCbCr 444 30bit”.

Many thx, this of course explains your observation. Just looking at the manual I was not able to derive what you’re talking about, sorry.

This makes sense now… Your second TV doesn’t seem to support 10bit, therefore our Vero is falling back to 8bit with that TV connected.
24p (what you label here as 1080p) files are output as 444 10bit (which would translate to 30 in your case) and 50p/60p are output as 422 12bit (which translates to 36 in your case).

This means: You’ve basically tested all cases in one. Without advertised deep color support Vero should only output 8bit, with advertised deep color support it will output 444 10bit for 24p and 422 12bit for 50p/60p. Everything’s fine :ok_hand:t2:


With that amplified HDMI run, you have a complicated setup. I suspect the full display capabilities of the remote display are not available through that. We would need logs to confirm that.

What’s been said above is true: AVRs seem to report bit-depth as 24/30/36 rather than 8/10/12. Also, if vero is outputting 4:2:2, bit-depth reported by AVRs could be anything. But the fact that vero is outputting 4:2:2 and not 4:4:4 means it is sending 10 (30) bits.

1 Like

Got exactly the same, also 10bit with 1080p

Thanks. I will print your answer out and use it for a reference in the future as I am sure to forget it. lol

I will now turn off the zone 2 each time I finish using it so as to avoid any conflicts.
I will print your answer out and use it for a reference in the future as I am sure to forget it. lol