Odd issue: HDR playback stopped working

As of a few days ago HDR files stopped working properly. Until then everything worked fine. In between nothing changed in the setup. Now HDR files either play in 8 bit (banding) or show a black screen with sound playing and the TV not detecting a signal. After playback is stopped kodi returns as normal. SDR files play back without issue.

I tried several reinstalls with the march and april builds to no avail (I did use the settings back-up function).

I have set the bit depth to 444, 10 bit in rc.local ( sudo echo "444,10bit" > /sys/class/amhdmitx/amhdmitx0/attr ) and made sure it’s executable. I also ran the hot-fix for good measure.

I have tried a different HDMI cable and connecting the Vero 4K directly to the TV, resulting in the same behaviour.

Here’s a log: http://paste.osmc.tv/ituboxeteq.vhdl

Did you restore your guisettings.xml from another machine?
Can you try a fresh one?

If you set the bit depth in rc.local, you should disable auto switching.


A fresh guisettings.xml didn’t make a difference. Auto switching was already disabled.

e: hmm, I tried connecting the device directly to the tv again and it worked properly. So it has probably something to do with my receiver. Why it did work before is and now it doesn’t… I don’t know, as literally nothing has changed as far as I know. At least not on my part.

I fixed the issue. I had to set the HDMI mode on my Yamaha receiver to another mode. Maybe the unit had reset itself to defaults somehow.

This thread can be locked.

What mode did you change it to?
Can you clarify in some more detail as I’m sure this will benefit other users.

Glad to hear this is resolved


Just a note for you to properly fix your rc.local: The sudo is not needed (and will cause problems) The line should be:

echo "444,10bit" > /sys/class/amhdmitx/amhdmitx0/attr

I have a Yamaha RX-v381. I needed to set HDMI to mode 1 (the default is mode 2) using these instructions.

Thanks, I’ll fix it in my rc.local