Official Fan for Raspberry Pi 4

Is there a way to configure OSMC to have the Official Raspberry Pi fan running in a similar was as in Raspberry Pi OS?

The staging repository should have them behaving the same way.
However you may wish to hold off updating for now as a user reported an issue after updating.

A bit late to the party, but people might still land here by searching for an answer.

I have the Raspberry Pi fan and installed it like explained here: Buy a Raspberry Pi 4 Case Fan – Raspberry Pi.

To set a threshold to start the fan, I did the following:

  1. ssh into the device
  2. edit /boot/config-user.txt and add these lines (70000 means starting the fan at 70 degrees Celsius) :
  3. reboot

EDIT: as per replies, don’t install raspi-config
Another way might be to install raspi-config as explained here: raspbian - Lack of 'Raspi-config' - Raspberry Pi Stack Exchange. However, I did not test this.


I wouldn’t do this, I believe osmc is based on debian rather than raspbian on the pi4.

Regards Tom.

1 Like

This should not be done – it will lead to problems.

1 Like

I’m in thr process of moving my OSMC installation from a Pi3 to a Pi4, mainly to take advantage of accessing my file staorage via USB3. I have the Pi4 mounted with an IQAudio DAC HAT in a HighPi case with a fan mounted. I’m thinking that I want the fan to be operable in order to prevent the Pi CPU from getting excessively hot under its HAT. I’ve done a fresh instal of OSMC and everything works OK except that the fan runs at full speed all the time and is therefore very noisy. I tried Mrmathos’ solution above but it makes no difference - the fan is already running as soon as the Pi starts to boot.

Can anyone give me any advice on a solution for this?

Are you sure you have it wired correctly? If your using the setting above pointing to GPIO 14 then are you sure you have the control wire attached to pin 8.

I have the control wire on pin 8 and did actually change that also to pin 8 in the statement above.

Pin 8 is the connection point for GPIO 14 so you should not have changed that and it being set to anything other than the correct number would cause it to not have speed control.

That wouldn’t be the first time I’ve been confused by GPIO pin numbering :grinning: Seems to be OK now though so I can tweak the threshold temperature to a suitable value. Thanks!