OMXPlayer won't play DVD

Hi all,

I’ve selected OMXPlayer acceleration (MMAL acceleration unchecked) in video player settings and my ripped DVDs won’t play. Logs are here:

I scanned the logs quickly (I really don’t know what I’m doing), and found this entry:

17:07:34.816 T:1926294016 NOTICE: OMXPlayerUnsuitable OMXPlayer unsuitable due to ac3transcode

So, evidently there is something about this DVD or the way I ripped it that makes it unsuitable for OMXPlayer?

These DVDs play pretty well using MMAL, although there is some stuttering from time to time. That’s why I switched to OMXPlayer. (I also like OMXPlayer because it doesn’t have the “skip back stalling” problem. It won’t play Live TV, but I really don’t need Kodi for Live TV.)

Thanks for any help.

You have AC3 transcoding enabled. If you disable this it will work (under Settings -> Audio)

1 Like

Thanks for the quick response, Sam, but disabling AC3 transcoding didn’t do the trick. In particular, I deselected Settings > System > Audio > Enable Dolby Digital (AC3) transcoding and tried the same DVD again and got the same results.

Logs are here:

You’ll note I get the same message:

17:07:34.816 T:1926294016 NOTICE: OMXPlayerUnsuitable OMXPlayer unsuitable due to ac3transcode

I rebooted and tried again, but the result was the same. Evidently, I’m deselecting in the wrong place?

I appreciate your assistance. Thank you.

I did some more looking and may have answered my own question: Evidently OMXPlayer doesn’t support DVDs with menus, and that’s what I’m trying to play in this case. If I’m wrong, please correct me.

If that’s the case, I guess I have to enable both MMAL and OMXPlayer. When I do this, Kodi chooses 1) MMAL for recorded TV when OMXPlayer would work, 2) MMAL for live TV when OMXPlayer doesn’t work, and 3) MMAL for DVDs that are not supported by OMXPlayer.

I was under the impression that if both are selected, Kodi would select OMXPlayer if it would work. My experience with case 1) suggests that’s not true. That’s too bad, because MMAL suffers from the skip back stalling problem when watching recorded TV.

Again, thanks for the help and please advise if I’ve got this wrong.

Your understanding is correct.
The logic for printing the “OMXPlayer unsuitable due to ac3transcode” is pretty simple:

So I suspect you still have the setting enabled. Try using the reset all settings to default option in the audio settings page and then test.

From OP’s guisettings:

    <ac3transcode default="true">false</ac3transcode>

Can anyone else reproduce?

Thanks for the feedback and suggestions. I’m not sure I understand what I need to do next, so allow me test my understanding of what you’re saying.

Popcornmix shows a code excerpt that indicates that, at that point in the code, Kodi thinks ac3transcode is true. Sam’s excerpt from the log says that ac3transcode is false. Do I have that right? If so, the change I made in the OSMC interface did not find its way into Kodi, although it did make it to the log.

Popcornmix suggests that I reset all audio settings to their default values, then set ac3transcode to false and see if OMXPlayer can play the DVD I’m trying to play. Evidently the hope is that some other section of code is executed that properly sets ac3transcode to the correct value. Is that where we’re headed?

I’m thinking the plan would then be to successively add audio setting changes to get back to where I was when I reset everything to their default values. Does that make sense?

Finally, what about my finding that OMXPlayer doesn’t handle DVDs with menus? Is that really the case? If it is, the DVDs in question won’t play with OMXPlayer anyway.

Sorry for being thick. Thanks again for your help!

I did as popcornmix suggested. I reset all settings to default option in the audio settings page. I selected the OMXPlayer and deselected MMAL in the players settings page. I tried to play the subject DVD and it would not play. The result looked exactly the same as before, but the logs are different. Complete logs are here:

I scanned the log file myself and found this:

08:07:43.340 T:1691349760 ERROR: OMXPlayerVideo: Got MSGQ_IS_ERROR(-1) Aborting

I’m guessing based on my previous digging that this means OMX aborted because the DVD I was trying to play had menus or something but I really have no idea. Any help would be appreciated.

I don’t have any DVDs that don’t have menus to try, so I can’t test if OMX works in that case.

My conclusion: I use OSMC to view recorded TV, ripped DVDs with menus, and live TV. OMX works great for recorded TV (even if AC3 transcoding is allowed, by the way), but it doesn’t work for my DVDs or live TV. MMAL works for everything, but it suffers from the skip back stalling problem on recorded TV. When I select both in player settings, OSMC chooses MMAL for recorded TV. I guess my solution is to use MMAL and live with the stalling problem, which is a known Kodi bug.

If I’m missing anything, please let me know.

I enjoy using OSMC very much and I appreciate everyone’s hard work and support. Thank you!

Upgrade to a Vero 4k and you’ll leave your omx/mmàl problems behind, all while supporting a great project.


Gotcha! :grinning:

I may post a message over on the Kodi board just for grins.

@popcornmix is the main developer for the Pi platform, so he’s definitely seen your issue.

I will check to see if this is a bug in Krypton backports.
It would be interesting if you could try a Kodi v18 (Leia) build and let us know if you still experience a problem.


Thanks Sam.

I thought I’d seen popcornmix over on the Kodi forum, so I’ll skip that post.

I just bought this Pi setup pretty recently, so I’d like to keep it going for awhile before I give up and head for the Vero 4K. (My wife would not understand. These projects always cost more than initially advertised. :grinning: ) No offense to you or the other helpful folks here.

Kodi v18 sounds interesting. Could you or someone else point me to how to try it? I suspect there is a helpful thread here on that topic; I just haven’t looked for it yet.

Thanks again for the help. I’m enjoying OSMC and appreciate the great support you folks provide.

There is indeed. See [TESTING] Kodi 18 (Leia) builds for Raspberry Pi

You may wish to take a backup first.