One of my tv shows won't be scanned correctly


I have all my TV shows in a folder on my disk that connect to my Vero 4K, and all my shows get scanned properly expect one show.

the naming as below (show name > season > episode ): > season 1 >

when I run update my library I can see my Vero is able to pull out the show name in the updating bar from the remote db (, but it won’t show up in my TV shows list .

I tried different naming with no luck.

this is the show link on TVDB :

Thank you

I have this show and it scanned without issue for me, though I use a slightly different naming scheme:

O.J.- Made in America/S01E01 - Part 1.mkv

I’ve never been a fan of periods to separate words within the directory or file name, but accept its a reasonable and supported practice. Just not sure how well it works when the show name is supposed to have periods in it, like this one. I also always substitute a dash for a colon in any show that has one (movies too) and it’s always been acceptable to Kodi.

Just some thoughts…


Get rid of the season folders and dots, stick to Kodi’s naming scheme. Before scanning, look up the show in question on and copy the spelling they used there to your folder’s name. If the machine storing your files runs on windows, you’ll either have to omit the colon or any other character not allowed in windows file names or replace it with a hyphen plus space before and after.

Thus, your folder should be named O.J.: Made in America and your episode file O.J.: Made in America.S01E01.ext.

If there are two or more tv shows of the same name, help the scraper distinguish between them by including the year of release according to in brackets after the series’ name like you do with movies. Example: Berserk and Berserk (2016).

thank you, it works for me

thank you, it didn’t work … I appreciate your help

Try to do the scan again, and then send logs so we can see what it’s trying to match.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: