One or more items failed to play :-(

Hi, first post so I hope I have all that is needed.

I have OSMC running on a Raspberry Pi 3b and when I try to run many video streams such as, but not limited to Popcornflix, I get the “one or more items failed to play. Check the log for more information about this message”.

I installed a VPN thinking it might have been a Geo restriction but that didn’t work.

I have previously had popcorn flix working on another raspberry pi several months ago but I used that pi for another project and just got a new one.

The logs are here.

Any help would be appreciated. Thanks.

OK, more info.

I have since tried a fresh download and install of LibreElec with Kodi 17.5, installed the Popcornflix addon only and had the same error.

So then I went to an earlier version of OSMC, 2017.01-1, which is about where I last had popcornflix and everything else working but still the same error came up.

So I am back to where I was in my first post with OSMC 2017.10-1, Kodi 17.5 and a VPN installed and connected.

I know this may be a addon specific problem but because it is not limited to popcornflix I figured it may be a Kodi setting causing my grief.

This clearly indicates that you should be addressing this with the add-on developer.

I have been to the Kodi forum and the addon specific forums but they all claim it is not their problem.

So here I am again still with the same problem and unable to use most addons because of the same error message.

I am guessing it is a network problem that is specific to the raspberry pi / kodi but as I said, I am only guessing.

Is anyone willing to help me diagnose the problem please?

Could you give a link to the forum thread?

In the second thread, you posted an OSMC log but it’s clear that openvpn isn’t even installed. So if popcornflix is geo-restricted to the USA, you’re going to get bounced.

Edit: my mistake. This add-on shares a similar name with something else it seems.

With or without a vpn and various location profiles, I still get the same error.

Well, you’ve demonstrated without a VPN.

It was suggested in the second thread that it works fine on Kodi 17.6. It might therefore be worth waiting a day or so until 17.6 hits OSMC.

That would explain a fault in popcornflix/kodi, but why do so many other addons have the same error?

Impossible to say. I recall from the Kodi thread that you removed all the other addons but is this a completely clean installation, except for adding popcornflix?

I’d still suggest you wait until the next OSMC update and we can take it from there.