Only getting audio with music files

Hi. Updated my Vero this morning and am now only getting Audio when listening to music.

Prior to this update, all file types had a “popping” appear on the audio at 50 minutes of being on - could get around this by stopping playback, going to home, changing to different hdmi channel, waiting a minute and then going back to the Vero.

Have tried changing the refresh rate under video settings from 60 to 50, and this does bring the sound back. However, after pausing the video,or changing to a different video file, the sound is again lost.

Here is a link to the uploaded log, hopefully one of you kind people can help me, thank you :smile: egevorabeg

Hi Martin,

You should certainly let me know about these issues, if you have in the past, and I missed it I do apologise!

I am a little confused as to the title of your question. I think you mean you’re only getting audio with music files; but not with video files? Correct?

I see you tried a hotfix – it didn’t apply, because it doesn’t exist anymore, but I’m certainly curious as to which one you tried:

13:58:37 T:1408234528 WARNING: script.module.osmcsetting.updates : User entered hotfix ID - lanevudaqu
13:58:37 T:1408234528 WARNING: script.module.osmcsetting.updates : Retrieving hotfix from -
13:58:38 T:1408234528 WARNING: script.module.osmcsetting.updates : HotFix Result - {"message":"Document not found."}```

With regards to your audio issues -- I am seeing some errors. Can you describe your audio setup, and can you take a photo of your Audio settings?

The very best


Hi Sam,

Thanks for following this up.

Yes, that’s correct, I’m only getting sound without any issues when playing music files. Other files formats are having issues with sound i.e. no sound unless I change down the frame rate to 50, and then there is no sound if video is paused.

In terms of audio; my Vero is plugged into an HDMI switch box (which has its own power supply) and that is then plugged into the TV, sounds comes from the TV speakers.

I did enjoy using the Bluetooth on the Vero for a while, but stopped using it when I started getting the popping sound after 50minutes of Vero use, as mentioned before. However, turning off Bluetooth did not resolve that issue, I had hoped the updated would have resolved it.

Here is a photo of my Audio setup as requested.

I didn’t run the hotfix because I wasn’t sure what it would do, nor where it had come from.

Many thanks for your help, really enjoy OSMC and Vero,

best regards,

Thanks, that’s all I need to work out what’s going on. Simply put: Bluetooth audio is still very experimental.

If you can, log in via SSH and run this command:

sudo apt-get remove --purge pulseaudio

Then reboot your device. You may need to reconfigure your audio settings. This should do the trick – but you will lose Bluetooth streaming capabilities by doing this.

Stay tuned for when Bluetooth streaming is stable, and let me know how you get on with the above instructions and if you need any help



1 Like

What was it set to before that ? If it was set to 59Hz, that will cause you problems with sound. Set it to either 50/60Hz, and you probably want to enable adjust display refresh rate to match video if your TV supports 24Hz and you have the resolution set to 1920x1080.

Thanks Sam,

The remove, purge, and restart seems to have sorted the no sound issue.

I’ll stick on a movie and let you know if the popping sound has gone too.

Many thanks for your help!


yay, no popping sound issue either after 50 minutes, thanks Sam. Looking forward to the update on Vero2, remote etc.

1 Like

Glad this is solved – there will be an announcement when BT audio is made more stable



Your screenshot seems to be missing a LOT of audio settings that show up on my Vero when set to advanced/expert, not sure why. A couple of them are passthrough and audio device

Because he installed PulseAudio Bluetooth streaming which changes how audio sinks are enumerated in Kodi.