OpenDemuxStream - Error creating demuxer


#1

Hello OSMC,

I have a plugin that logs in and plays streams from a website. It requires a login to play the streams, and it works fine on PC. However, on OSMC, as you can see in my log file, I get the OpenDemuxStream error when I try to open the stream. As you can also see, the other links play fine in the addon, but this 1 stream seems to fail. Is the stream link too long and complicated, or what can be the issue here?

I opened this thread on Kodi forums aswell, but with no luck - so I thought I would try here.

I have tried reinstalling the addon, tried opening the stream (http://viasatlive12-i.akamaihd.net/… ), then opened the stream that works (http://dr01-lh.akamaihd.net/…) and did this a ton of times around 10:11:28

Device: Raspberry Pi 2
Installation media: SDcard
Connection: Wifi
OSMC version: newest
XBMC version: Kodi, newest
Codecs: none
Audio/Video Output: HDMI
Overclocked: Very little
LINK to log: http://paste.osmc.io/wehawiluka.1c


#2

please name the addon, cause if it is a banned addon you already know the answer


#3

Your problem is most likely that the streams are encrypted and/or in html5 which Kodi on Pi will not play…

http://forum.kodi.tv/showthread.php?tid=141630&pid=2004728#pid2004728


#4

Surely it’s not banned.
It’s an addon that allows my paid stream to be played in the PI rather than only in the Viaplay app on TVs, PS4 etc.


#5

This does seem likely, however that thread states it’s a problem in Kodi.
However, on my PC, Kodi plays the stream just fine.


#6

From the OP of the Kodi thread I linked above -

For the time being the plugin is only supported on Windows, Mac OS X and Linux (Ubuntu or XBMCbuntu) with Chrome and Pipelight (for Silverlight) .

So… Not for Pi…


#7

This seems like the answer, although it seems weird as the plugin works on the old Raspberry PI 1 ?


#8

The viaplay add-on launches in an external browser and requires silverlight (and so an x86 processor) so it’s not possible to run it on a raspberry pi (or any arm platform).

Are you able to run the add-on on the raspberry pi 1 that worked? A debug log would be interesting. If it does still work then I suspect it is using a different add-on.


#9

This plugin however is not the official Viaplay addon, I dont Think this launches a browser - doesnt look that way at least.

It works flawless on RPI1. I tested it yesterday, am not able to provide log untill a few days


#10

This is an issue you should be addressing with whoever wrote the addon. It sounds very hacky and, as you haven’t reported such, I’m very doubtful it’s been configured to work with Isengard.


#11

Already talked with the creator, he did not know the problem as he doesnt have a RPi2.

Its funny how everything unanswerable becomes criminalized.
Its NOT hacked, its just to avoid the browser requirement, and it works on Raspberry Pi1.

Ill post a log when I can, this issue is weird as fxxk


#12

Hacky does not insinuate criminal or illegal. More so programatically messy, inelegant, or troublesome. What you aren’t seeming to understand here is that the sources of the content are providing it by protocols that are not usable by a Pi. This is the same issue plaguing the device in regards to netflix. Unless you can provide some confirmation that this addon is utilizing a stream in a format that is not dependent on silverlight or html5 capable browser, then there is no reason to assume this is an OSMC issue.

What I don’t understand is, what benefit do you get from using this “homebrew” viasat addon over the official?


#13

I’m sorry, my native language isn’t english so I took it that you - like previous posters - insinuated that the plugin was not legal.
I can get a debug log from my RPI1 when I get home, which can show that it plays on my RPI1.

I could also upload the plugin for you to look into, if that could help the issue. I am not sure either whether or not it’s an OSMC issue, but over at Kodi.tv, they believe the issue is not in Kodi, because of the fact that it works on RPI1.

The benefit I get is, that it enables me to use my Viaplay account in a simple addon, that plays on my Raspberry 1 (and hopefully 2 some day).


#14

For this kind of error "OpenDemuxStream - Error creating demuxer " I’ve solved installing on RPI2 ffmpeg + mplayer + mplayer2 and mpv

These are the steps:

sudo apt-get install mplayer mplayer2 mpv

To install ffmpeg need to be compiled from source see this link for instructions:


The only step to change is the one regarding the version, in the link above is stated the ffmpeg-2.7.2.tar.bz2 the most recent one is ffmpeg-8.tar.bz2 and I’ve used this last one.

The compilation of ffmpeg it takes very long time; install and reboot.

After all of this I got not that error anymore

by
den


#15

You can close the thread, I solved it by installing OpenELEC instead - something in OSMC just different than OpenELEC apparently :frowning:


#16

I’ve fixed in this way

sudo -s
echo "deb http://www.deb-multimedia.org jessie main non-free"  >> /etc/apt/sources.list
echo "deb-src http://www.deb-multimedia.org jessie main non-free"  >> /etc/apt/sources.list
apt-get update
apt-get install deb-multimedia-keyring
apt-get update
apt-get install ffmpeg x264 mplayer
exit
exit

#17

Hello,
I have same error: Error creating demuxer.

I tried to install ffmpeg, x264, mplayer. First two installed but mplayer failed with: Preparing to unpack …/mplayer_3%3a1.1.1+20150226+svn37375-dmo5_armhf.deb …
Unpacking mplayer (3:1.1.1+20150226+svn37375-dmo5) …
Processing triggers for mime-support (3.58) …
Setting up mplayer (3:1.1.1+20150226+svn37375-dmo5) …
update-alternatives: error: alternative path /usr/bin/mplayer1 doesn’t exist
dpkg: error processing package mplayer (–configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
mplayer
E: Sub-process /usr/bin/dpkg returned an error code (1)

any suggestions how can i fix this?

p.s. i installed kodi on ubuntu 16.04 with IPTV simple addon and same error. error creating demuxer.I have installed all packages @dentaku65 mentioned.

Thanks,
Tadas


#18

Try mplayer2 :slight_smile: