OpenDemuxStream - Error creating demuxer

Up to date OSMC on Vero 4k. Installed a legal streaming video addon in Kodi, CBC 4.0.3, which is now in the official Kodi repo.

Log file show the error in the topic title here. Have posted a query in the addon support thread but a bit of research in the meantime suggests this may simply not work at all on Pi2/4k devices… Is this the case, and if so, why?

[Kodi Log]
(Ubuntu Pastebin)


You haven’t enabled debug logging so… Not very useful.

Maybe you are being geoblocked and it is not supported in your region

Full Debug

There is no regional blocking of CBC material within Canada.


DEBUG: Error, could not open file*~hmac=32f0b80a6ce9635e2e7eaf47123860527411204fa78be5a879bd793190084e39

Looks like the stream is being blocked to me.

It’s not geo-blocked or region blocking as I can start any of the TV streams using the CBC official app for Android on my phone, same WiFi network as my OSMC. So back to the app developer.

I had tried numerous streams on the Vero 4k and none worked, but I just now found one that does work so I no longer think this has anything to do with the 4k or OSMC. This was my goal for posting here as the addon dev is obviously the best one to support the addon. I had just found a couple of references to the titular error with respect to Pi2/OSMC/4k, but that doesn’t seem to be the case.


1 Like