Openvpn and OSMC 17.6 on Rpi3


Whether a clean install or an upgrade, openvpn does not seem to be doing DNS anymore.
It was fine the other day when I was using 17.5 and older, now nothing. The vpn connects fine, but no DNS is being done.

Any help?


You probably need to have a look through this thread.

Guess your ISP blocks external DNS requests.
Check this


Thanks, for the replies.
I solved my dilemma by simply changing the DNS addresses that my router gives out from DHCP.
I used and
Problem solved! Everything works like it used to, even Indigo’s system information shows my new external IP and the DNS I assigned.

Might be an easier solution, for people who are not Linux savvy.

Thanks again,


I wanted to say that, while I appreciate the notoriety and being held up as an example of successful problem solving, my issue(s) was not necessarily due to the DNS server (Comcast) I was using nor to any VPN leakage (at least, as near as I could tell).

My issue seemed to be more of a result of a prior update that crashed my RPI 3/OSMC system (possibly related to power supply issues). I reset my system, left the DNA server addresses intact and re-enabled vpn. And the system worked fine after that. However, I have since moved over to “open source” DNS servers just in the off-chance they were a source.

Again, thanks for my 15 secs of fame :slight_smile: but don’t rely on my solution to be the answer to most or all of the issues that seem similar to mine.

Thanks and cheers…