OS stability issues


I’ve been using OSMC on my Pi 3 for about a year now.
It works fine, sometimes it freezes and stuff like that but I can’t blame OSMC,
Since Kodi is not the most stable platform.

The problem I am facing is that every few months I’m forced to re-install OSMC from scratch because of different odd issues (file system errors, OS errors…)

I was forced to re-install OSMC from scratch for atleast 5-8 times already.

For example, today, I played around with the new version, saw that it was working okay but not the smoothest (lags).
So I took out the SD card, made a full image backup and put it back into the pi and started to play with the overclock settings.
After a reboot it says something about file system errors and then tries to fix it but fails.
So I format the SD card and load into it the img file i just backed up.
Pi boots, same error, same proccess, so I am forced to re-install OSMC again?!?!?

What could be causing these odd issues, and so much instability?
When I format the SD, what file system should I set?
Anything you can help me with avoiding these kind of odd issues from re-occurring?

Something is wrong with your hardware. I think most users will tell you that OSMC is a set it and forget it setup.

A user shouldn’t really be installing more than once every two years, provided they are keeping up to date, unless they’re making significant modifications to their system.

Get another SD card and power supply.
Don’t mess with overclock settings unless you know what you’re doing.

The amount of overhead available on a Pi3 for overclocking is really not enough to result in tangible perfomance increases… Best to just run at default.

1 Like

I have one PI B+ here with broken SD Card, and it is very weird how it behaves (Actually, everything can be written according to the OS, no errors show up, but it actually does not write it down).
On the other hand, I had a Vero with the exact same symptoms. As soon as the Powesupply was replaced, it worked straight again.
So what @sam_nazarko said in a pervioius post definitly apply.

1 Like

Also for me it stinks like an issue with the SD card (you don’t have to care about the format since while OSMC installation partitioning and formatting is done anyway).

I suggest to

  1. format the SD card with an appropriate tool on your PC like https://www.sdcard.org/downloads/formatter_4/

  2. test (!!!) the SD card on your PC; I personally prefer this tiny program for such jobs H2testw | heise Download (sorry, the web page is in German but the meaning of the green button “download” should be understood)

  3. reconsider and check whether you want an automatic basic check and repair of the file system on every start of OSMC (don’t know whether this is already worked in to OSMC distribution with Krypton for Pis). See i.e. Automatic fsck of root filesystem on start/stop

OSMC already fscks on boot automatically since November 2015.

1 Like

Excellent; since I made made my changes in fstab and cmdline.txt by myself before, I never was aware that is already implemented that long time.

I’d bet OCing

Thank you everyone for responding!

My power supply seems to be okay, it is 5V 2A and there are no symptoms of power supply issues (the colored square and all that).

I’ll try to install my backup on a different SD card and see what it does, will keep you updated.
And @littlalex what’s OCing?
I’ll also try that SD tester software


Also, 2.5a is the minimum recommended for running a pi 3.

Sorry, overclocking.

I also used a phone adapter for the RPi3, and had similar issues. After buying a Raspberry brand a/c, I never had any of these problems anymore…

1 Like