OSD going sometimes off screen


On my vero4k I noticed that ONLY for some of the videos I’m watching, if I invoke the OSD, it gets partially off-screen, i.e. top info bar goes beyond the top, bottom bar with the played time almost under the bottom, etc. while for other videos it’s just fine, all infos are shown entirely inside the viewable screen.

After sampling a bit where the issue appears (mostly using the Youtube addon) it seems that videos that are played “well” have" an fps of 25.00, 30.00 or 50.00.
Instead, the ones with an fps of 29.970 have the issue.
Similarly, for a few movies or other videos I have stored locally, those at 23.976 fps are also problematic.

So, it seems to me non-integer fps values are a symptom of this off-screen issue.
How can I solve that?

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

I have a relatively old Toshiba LCD TV, and in the Picture settings there is only a choice of Autoview, Dynamic, Standard, Movie, Game and PC.

Absolutely no mention of “overscan” in the TV settings or the TV manual.

So far I did try only Standard and PC, as I thought they were more ‘neutral’ choices, but now I see at least Game mode seems to fix this issue (although maybe the image is slightly shrunk, as if I’m not mistaken there is a wider unused area around the border, but that could be corrected via Kodi/OSMC calibration, I guess)

Your TV may have aspect settings specific to each display mode so you may have to play with the TV’s settings each time it does this until all the various inputs are set to 1:1 aspect (ie no overscan). This issue can also be caused by using the video calibration options in Kodi which should really only be used if your display lacks aspect ratio settings. If you had adjusted these then I would suggest to reset the calibration back to default.

Yeah, before trying to change the picture mode I did reset the Kodi calibration to default (which anyway wasn’t changing too much).
While each mode had a distinctly different brightness/contrast/color setting, I think only the Game mode was showing a slightly shrunk OSMC screen.

Anyway, I selected that TV mode (which applies only to that specific HDMI input), further adjusted brightness/etc. and finally used the Kodi calibration to extend the used screen to the full frame, and I think I’m good (@fzinken answer marked as the solution).