OSMC 2016-02 on Raspberry Pi controls do not work while playing video

I just got my new RPi3 and installed latest version of OSMC on it.

Configuration change ive made:

  • Switch on OMXPlayer for HWaccelleration, otherwise no video and very choppy audio, assume this is normal change everybody does?
  • Disable CEC as it interferes with my receiver

However, when playing a video (for instance an x264 mkv), i can’t control Kodi anymore, keyboard doesn’t do anything, it seems to switch off completely as caps/numlock lights also no not respond. Also my Yatse remote control app seems to think that the server is down and no remote control command is possible. While before starting the video everything works fine.

I’ve tried to change the power source from a phone charger to a new dedicated raspberry pi power source which i’ve ordered with the RPi3, but situation remains the same.

What could this be?

Sounds like power issue. Did you add max_usb_current=1 in config.txt?
Try to change power supply and cable.

Changed the power supply already, will see it changing config.txt helps

Nope, it did not work :frowning: Still no controls whatsoever while playing.

Logs would be nice.

13:45:59 30.322306 T:1957511728 NOTICE: DVDPlayer: Opening: smb://MEDIASERVER/Media/tvshows/file.mkv
Everything is fine

After that you see
13:47:14 105.712860 T:1707078640 NOTICE: ES: Client from timed out
Which is probably my phone with yatse on it, but the usb keyboard also shuts down…

Please use grab-logs -A

Sorry not used to those conventions yet :wink:

Here it is:

Have you ever attempted to run any updates? You should.

Without a doubt this will be a power related issue. Try a different power adaptor.

Yes i have, after downloading the latest version of osmc yesterday i also performed an update…

I’ll be d*mned… tried to update once more just now, updater finds packages, updates… all is well…


Do you ever see the rainbow colored square in the top right of your screen?

1 Like