OSMC 4.2.3-3 (kernel update) not booting - reposting due to premature closure of original thread! (Issue resolved ! :) )

Continuing the discussion from Latest udpate - OSMC 4.2.3-3 (kernel update) not booting after update:

Yes I udpated yesterday… 15 mins before I started this thread. I do not see any rainbow screen… nothing at all. when I power the Pi, green LED blinks twice, red stays solid.
here is the directory structure of fat partition:

 Volume in drive F has no label.
 Volume Serial Number is 43D2-C0F8

 Directory of F:\

06/07/2015  10:36 PM                95 preseed.cfg
09/23/2015  06:05 AM         3,810,376 start_x.elf
10/13/2015  01:15 PM         1,941,213 System.map-4.2.3-3-osmc
10/13/2015  02:00 PM            10,454 bcm2708-rpi-b-plus.dtb
10/13/2015  02:00 PM            10,175 bcm2708-rpi-b.dtb
09/23/2015  06:05 AM             9,597 fixup_x.dat
10/13/2015  11:26 AM           107,476 config-4.2.3-3-osmc
10/13/2015  05:32 PM    <DIR>          overlays
09/23/2015  06:05 AM            17,900 bootcode.bin
10/13/2015  05:32 PM         5,710,088 kernel.img
06/17/2015  07:10 PM               303 config.txt
01/01/1980  12:00 AM                63 cmdline.txt
01/01/1980  12:00 AM             2,246 install.log
10/13/2015  05:32 PM    <DIR>          dtb-4.2.3-3-osmc
10/13/2015  01:15 PM         5,710,048 vmlinuz-4.2.3-3-osmc
09/23/2015  06:05 AM             1,447 LICENCE.broadcom
              14 File(s)     17,331,481 bytes
               2 Dir(s)     233,436,160 bytes free

Is this a model older revision model B that uses the regular (larger) size SDcard? Are you certain it’s making good contact with all contacts in the reader slot?


yes this is the older model B with full size SD card. I have reseated the card. no luck

Can you try applying some pressure to the card while attempting to boot? Pressing the flat side of the card tighter against the contacts.

didn’t help. I even copied the card to img file, then restored the img to a new SD card. still the same issue.
can I copy the fat partition from another PI?

Another pi running OSMC? Should work. I compared your posted files and sizes and they matched mine. I’m deferring to either Sam or dbm.

Thanks. I just flashed fresh image from osmc installer on a new SD card, will update using dist-upgrade then copy the fat partition to the busted osmc SD card.

Fat partition copy from fresh install followed by dist-upgrade worked !!. old SD card operational now everything working … Phew !! :stuck_out_tongue: