OSMC Alpha 1 is here!

Ohhh, that’s why I wasn’t able to get it to work!!
Well, for now I used connmanctl config, looking forward for Alpha 2.

Will that ‘stuck’ package be fixed with alpha 2?
Would be nice to not constantly do all the settings and installs of course :smile:

I hope so. I’m quite new to Debian packaging so it’s possible I have not fixed the issue yet…

1 Like

I’ve finaly install this and it’s amazing how smooth (in comparison to Raspbmc and Openelec) it is! I considered buying Intel NUC or Gigabyte BRIX but now i don’t have to :smile:

But I have a problem playing files which are compressed with RAR (There is file.rar, file.r00, file.r01 … file r50 in one folder). Only audio is playing. File after extraction plays OK so archive isn’t corrupted. On Kodi file list there is only first rar file with size of 95 MB - normaly there should be one file (contents of archive) with full size - for example 5 GB. Everything works OK in Kodi 14 RC3 on Ubuntu

Log: http://paste.osmc.io/wujukejoyu.js

Likely needs mpeg2 codec.

Indeed. We plan to have an add-on soon allowing you to enter these settings, but for now you’ll have to edit /boot/config.txt manually

Hmm, but when I extract this file it’s working. Here is mediainfo of this file: http://paste.osmc.io/wuferavulo.vhdl it looks like mpeg4.

LaBoss: OSMC uses systemd which requires some changes to nfs mounts in /etc/fstab.

Make sure you are not using the _netdev, auto, or bg mount options.

Make sure you add the following two mount options: x-systemd.automount, noauto.

noauto prevents it trying to mount at the beginning of the boot process before the network is up (which is causing the error you see) while x-systemd.automount will cause it to be auto mounted on first access after the network is up.

This works for me. The optimal settings for nfs mounts are still subject to change during the alpha releases though as the boot process is still being tweaked.

3 Likes

Hello DBMandrake thanks for help… with this options all work fine :slight_smile: the fstab It was so for those who Want

   10.10.10.10:/export/Filmes           /media/Filmes     nfs     rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0
10.10.10.10:/export/Fotos            /media/Fotos      nfs     rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0
10.10.10.10:/export/Series           /media/Series     nfs     rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0
10.10.10.10:/export/Musicas          /media/Musicas    nfs     rsize=8192,udp,cto,noatime,intr,x-systemd.automount,noauto,nfsvers=3 0 0

DoubleL: until the new settings addon is ready you’ll need to add the codec lines directly to /boot/config.txt yourself.

You can either use ‘sudo nano /boot/config.txt’ from an SSH session to edit the file, (then ‘sudo reboot’ for the change to take effect) or shut down, insert the SD card into a PC and edit config.txt on the FAT partition.

Hi Sam, great work (again), can you tell me if you can also do an update from the currently installation (I prefereren not to set-up everything again ;))

Bye,
Abel

This is alpha1, it would be unwise to assume that until final stable release that a reinstall would never be required. No build that arrives before final is intended to be run with the expectation that it would be run as a fully functional, stable system.

Quick and dirty first impressions. I’m trying to pack for vacation, so I didn’t have time to do more thorough testing. And, yes, I’m taking OSMC with me, but I have a Raspbmc backup SD….

With some very minor exceptions, everything works well for me. Installation was flawless. Menu response time is very quick.

  • Unable to install skins. Gets to 98% and quits every time. Other add-ons installed OK, so it’s not a network problem. (Bad for me as I really dislike Confluence….)
  • I’m guessing mDNS is not implemented. No network browsing. Easy enough to manually add sources.
  • If KODI is scanning for thumbnails and video info, attempting to play a file in that directory returns a false report that the file does not exist. Once the scanning is done the file is, of course, really there and plays just fine.

All this on a wired B+ with an 8GB SD card.

Sorry for the excessive brevity.

Can you name which skins specifically are you unable to install ? I’ve installed Black Glass Nova successfully but didn’t try any others yet.

mDNS name resolution was accidentally left out in Alpha 1 but is already fixed and will be in Alpha 2. This only affects browsing bonjour/zeroconf sources however, if you mean SMB sources this may be a separate issue.

Where are the files located - on the local SD card or across the network, if across the network, using what kind of network file system ? By the way the extract thumbnails setting is off by default, did you enable that ?

And when you say it is scanning for thumbnails and video info do you mean in the file list, or are you doing a library scan ?

Thanks for testing.

Hi Pablo,

Make sure you have “Support browsing into archives” enabled in Settings->Appearance->File lists. Browsing into archives is disabled by default in Helix because this can cause major slowdowns on a device like a Pi if you have a lot of archives in the same directory as all the archives in the directory must be extracted just to generate the file listing.

If you do use this feature make sure your archives for each movie are in their own separate sub folders. (This is best practice to have movies in their own separate sub folders even if you don’t use Archives)

1 Like

DB

  • Skins: Over a six hour period I tried to install skins, mostly at random, over a dozen times. Every time the same result: quick download to 98 or 99% and then it just stops. I was never able to download any skin. The skin I wanted was Silicon Dioxide. Tried many times; never succeeded.

  • Browsing: I was never able to browse any share. Although SMB shares showed up in the Zeronconf browser, attempting to browse them resulted in nothing: a brief “working” notice and then a return to the menu. Same with AFP and NFS. If I specifically select SMB or AFP or NFX (not Zeroconf) no shares show up although there are several on the network.

  • Scanning: The files are located on an AFP/SMB share hanging off of an Airport Extreme. I did enable the thumbnail and video info setting. This is not a library update. I did not have this problem with Raspbmc, only with OSMC. What I’ve now noticed is that whenever I restart KODI it will be some time before individual files are playable. I presume that it is rescanning making the files temporarily unavailable. This is not a huge problem, but the error message is misleading; leading one to believe that the file is missing when it is actually just temporarily unavailable.

I’m sorry, but I’m not going to be able to do much more. I will leave a Raspberry Pi with OSMC installed at my condo. At home, I am still on Crystalbuntu and Raspbmc. I won’t be able to upgrade the home installation until OSMC is available for the ATV1.

I’ve just tested installing skins on a completely fresh install of Alpha 1 - no other settings touched.

I installed 1080XF, Aeon Nox, Black Glass Nova, Conq, and Transparency. All installed ok.

The only one I noticed any issue with was 1080XF - there was about a 3 minute delay between “loading 96%” and it offering to switch to the skin. This is not unusual on a slow device like a Raspberry Pi, and I have seen this before on Raspbmc on “heavy” skins.

Another issue that can happen during skin installation on a slow device like a Pi is that the “keep this skin” dialogue can time out without any chance to press YES (this also happened to me with 1080XF) - this is because many skins do some initialisation/house work during first run and until that is finished you can’t select the YES option, however on a slow device this can take longer than the timeout for the keep this skin dialogue, which cancels the skin change.

This was also an issue with Raspbmc and is a general Kodi issue on slow devices. The solution is to go back into appearance and reselect the skin after it is installed.

If you’re not able to install any skins successfully that suggests a network issue - remember that many skins rely on other scripts/addons, which will install after the skin itself has downloaded. (typically at 95-99% indicated progress) If any one of those fails the process may hang at that point.

So the most likely cause is that a firewall or your ISP are blocking the website that hosts one of the addons required by the skins. The only way to know would be to turn on debugging and capture a debug log for us.

Zeroconf is not used to browse SMB shares - unless the device itself advertises the share via Zeroconf. (This is not part of the SMB standard) I believe this is the case for Mac’s but NOT for Windows by default. As I said, zeroconf name resolution is currently broken but will be fixed in Alpha 2.

The built in SMB browser in Kodi/XBMC has always been flaky on Linux and the Kodi devs have said as much - I have never been able to use it reliably on Raspbmc either, and always manually entered the shares.

It’s possible that this could be improved by adding winbind support in nsswitch to allow Netbios name lookups outside of Kodi, which I plan to investigate soon, but this was never a part of Raspbmc either.

What is probably happening is that Kodi is trying to open too many simultaneous file share connections to the same server (it tries to scan many files in parallel) - and I believe that the Airport Extreme has a limited number of simultaneous connections that it will accept.

I saw similar behaviour in Gotham on Raspbmc when testing over http with an http sever that sets a maximum number of simultaneous connections.

It might be that Helix tries to open more parallel connections at once so potentially if you have a lot of un-scanned files in a directory it is trying to open more connections than your server allows. A debug log would be helpful here too. There might be a way to limit the maximum number of thumbnail connections that are opened at once, but general advice would be not to use thumbnail scanning on the Pi and use the Library instead.

Everything is in boxes now so I can’t try anything new….

I should note that I originally had Raspbmc and XBMC 13.2 on this very same Raspberry Pi with the same network and media files hosted on the Airport Extreme. With that configuration:

  • I had no trouble installing skins, so it’s probably not a network issue. With Kodi the skins never get installed. I looked in the addon directory and there’s nothing there. There are no skins to select; only Confluence.
  • As you note, the SMB browser was flakey on XBMC as well.
  • I did not have the scanning issue, even though scanning for thumbs and video info was turned on. Media files were identical. So, it’s probably not an Airport Extreme limitation. The total number of media files is about 50.

I’m sorry I won’t be able to provide a debug log. I don’t think I will have much in the way of Internet access over the next ten days or so.

I’m closing this thread as Alpha 2 is now out: see http://bit.ly/16TEmFi. Please make sure that you’re running the new build before you report any issues. There is a new Alpha 2 discussion thread here: OSMC Alpha 2

Cheers

Sam