OSMC Alpha 1 is here!

LaBoss: OSMC uses systemd which requires some changes to nfs mounts in /etc/fstab.

Make sure you are not using the _netdev, auto, or bg mount options.

Make sure you add the following two mount options: x-systemd.automount, noauto.

noauto prevents it trying to mount at the beginning of the boot process before the network is up (which is causing the error you see) while x-systemd.automount will cause it to be auto mounted on first access after the network is up.

This works for me. The optimal settings for nfs mounts are still subject to change during the alpha releases though as the boot process is still being tweaked.