OSMC and Hyperion


A long long time ago (when animals were still talking) I used this guide to make mine: http://davenewson.com/posts/2013/ambilight-with-teensy-2.html

I was still using boblight (which was a nightmare on cpu compared to hyperion). HW-wise this guide should tell you all you need to know.



do you have or know where I find a complete tutorial on how to enable Hue with Hyperion? Hyperion FAQ does not really help in this regard. I need it for just one light ID (1) which is a philips hue lightstrip.

Thank you!


We should work on a HOW-TO for Hyperion until the new version lands.



What exactly is unclear about the FAQ. I found this in the wiki which (to me) seems clear on how to configure a hue lightstrip. But I have 0 (zero) experience with hue so I might be missing something.

What exactly is not clear? Is it installing hyperion, configuring the hue lights, configuring the grabber?


No info on how to set the lightID’s in hypercon. I added them manually in json, no idea if correct or not.
Biggest problem is that I receive a connection error (even if it is clearly connected to libreelec). And also that 3 months ago when I first tried this and received some errors I did not get any help on the forum.


I quickly checked Hypercon and indeed it does not appear to to have the option to configure the lightID’s. This should be reported to the developer. There’s quite some supported LED’s so I can imagine whoever wrote Hypercon does not have in depth knowledge of all the specific options needed for each LED.

What “connection error” do you get? Connection from hyperion to the hue bridge or some other error?

I’d say give it another go. Which forum did you report to 3 months ago so I can have a look at those errors.


Hypercon won’t be enhanced.

If Hyperion.ng web UI doesn’t yet do it, please open an issue on GitHub


Thanks for input. Here the old errors:

As for connection error, I receive after I connect to LE and upload the json file. You have the color “test?” options. There I have the error. I will post exactly later.

Hyperion.ng … server not found.


Had a quick look at the thread you posted. Your config for the LED’s seems OK as they are switched on/off when playing something. So at least hyperion is doing something with the LEDs.

A quick google indicates the Wetek Core also uses an AMLogic CPU (like the Vero) so my guess is you should add something simular to this to your config:

"amlgrabber": {
"width" : 64,
"height" : 64,
"frequency_Hz" : 10.0

This should grab the video and switch on the LEDstrip.


You sir, are a genius. It works.
Now I have another issue. LED’s turn on only on high brightness images (like start of Suits episode). Other then this it either does not turn to any color, or LED’s are on an extremely low brightness setting.
Testing with a movie (so black border), seems to be even lower in brightness level.
Anyhow, finally some progress. Thank yo very very much.


Seems it is known…:


Have a look at the color calibration section of the config. You can tweak it a bit around.


Given the repeated issues with initial compilation/installation I’ve put together a repo and script for this purpose. This is now compiling directly on the Vero 4K, rather than a cross-compile from the RPi3 as I’d done originally (I realise some new users won’t have another box to work from). It works.

The final test will be to run it from a clean OSMC reinstallation which I should be doing next week, to ensure I’ve not missed any depends etc for a new user to stumble over.

My one concern is that anyone using all internal grabbers needs 2 entries in the config, for both “framegrabber” and for “amlgrabber”, as @nrosier pointed out to me. This needs to be addressed or there will still be the traffic to this thread over basic installation issues which I was trying to avoid.

There doesn’t seem to be an option in HyperCon.jar to allow for this. The “Internal Frame Grabber” is enabled or not and that’s it. So they would have to manually edit /etc/hyperion/hyperion.config.json if that’s their thing. I could insert the:

"amlgrabber" :
            "width" : 70,
            "height" : 40,
            "frequency_Hz" : 24.0,
            "priority" : 799

portion using sed into the default config file, but this would be overwritten when they send their config over from HyperCon.

Do I just point out the pitfall in the README? Will they read it?!


Nice “hack” to bypass the QT5 breaking package. That’s the main reason I’m using a RPI2 to build my images. If you run a make package you get several packages (deb,tgz and sh iirc) which you could use for installation or upload to your repo.


Yeah, that was my little breakthrough! Like symlinks to libraries it’s a bit dirty but works. I’ve learned so much recently with a lot of late nights, reverse engineering, my first git repos etc. Nice to contribute.

I’ve not tried building a package yet. Was getting around to it because I’m examining Retropie-setup at the moment to see how that works and I noticed they did that with their SDL2 build/install.

I seemed to remember Github wasn’t meant to host binaries, or it was frowned upon, but not sure where I read that now. It’s an interesting idea. I could do the same for the emulators I’m working on in theory.

Any suggestions how to proceed re: the config in my previous post?


Hyperion stores their builds on sourceforge iirc, not on github. if you want to build and share you could do it there.
But I think either everybody should build there own binary with needed options or there should be an all-included version. I use the v4l-grabber for anything that doesn’t talk to hyperion (BR, Game-console etc…) so I build that one as well. But others might need other extra’s. Problem is I like “lean” binaries which only include what I use.

As for the config; it’s a bit the same as with the binaries. It’s a config and it’s specific to your config and what you use. Which LED’s, how many, which grabbers. So a one-size-fits-all config is impossible. I’m waiting for OSMC to upgrade to Stretch so I can have another go at hyperion.ng and the new web interface. From what I read it replaces hypercon which should help people configuring their setup.


Yeah the web interface is nice, just incomplete at present. Same with the new Android app. It’s all going to be very swish when it’s done.

The use case with the config might actually be worth a feature request come to think of it, otherwise NG will be in that same boat when it’s done.


Linux noob here.
So, if I understand correctly I need to run both

sudo apt-get update
sudo apt-get install git cmake build-essential qtbase5-dev libqt5serialport5-dev libusb-1.0-0-dev python3-dev libxrender-dev libavahi-core-dev libavahi-compat-libdnssd-dev


sudo apt-get install rbp-userland-dev-osmc

then run

wget -qO- https://raw.githubusercontent.com/hyperion-project/hyperion.ng/master/bin/compile.sh | sh

and I should be done?


Or try my installer?


sudo apt-get install git
git clone https://github.com/hissingshark/hyperion-vero4k.git
cd hyperion-vero4k
sudo ./install.sh

Follow the menu from there.
You can install a pre-compiled binary or build your own from source with just the options you need.


I’ll give it a try, thanks.