OSMC and Samba - How to transfer files from Windows

Hello,
I just installed OSMC and saw some videos on how to create a NAS to send files to the drive to the Pi, but none of them worked. Then I read that you can use a app from the Store to configure Samba, I did it but I can’t see my disk on the Network folder of my computer. So, how can I send files to the pi from windows? Using windows 10 and a RPi2.

Thanks in advance,

I don’t know if ok for you… but i use FTP and Filezilla from PC after i have activated the SFTP server on OSMC.
After that simply using the root access whit root / osmc credential…

What I wanted to do was to have a hard drive connected to the Pi and from windows send data to it, but without using of 3rd party software (as others in the house might want to use it and they don’t understand that much about ip’s and related. So I thought on having the folder visible from the network and say “all you have to do is to put your movie here”.
But since I changed a lot of stuff I’ll make a clean install of osmc try to use Filezilla and FTP to see if it’s works. Thanks for the tip!

No need for FTP! When you install the SMB server from the APP Store everything is ready to go. Depending on how you mount your external drive you might need to add it to /etc/samba/smb.conf but generally all is plug and play.

The problem is that I don’t have the Pi on my network to access to it, but it’s connected to the internet since it received updates (and checked my me with the terminal)

This sounds strange are you saying:
A. you have on purpose not connected the Pi on the same network?
or
B. You have connected it to the same network but you can not see/access it?

I have the pi on the same network but I can’t see/access it.
Now that I see my last post I can understand that it wasn’t clear.

Ok, to troubleshoot it would be the easiest if you could login to the Pi with SSH.
Suggest you install putty on your windows machine and the login OSMC information how to access OSMC via command line locally or via ssh can be found here: https://osmc.tv/wiki/general/accessing-the-command-line/

After your login run:
sudo systemctl status samba to see the status of samba (should show “Active”)

If the previous test is successfull then on your Windows PC go to command line and run
net view <IP of OSMC> that should show you things like
Samba 4.1.17-Debian

Share name      Type  Used as  Comment

-------------------------------------------------------------------------------
boot            Disk           Auto-mount Volume
osmc            Disk           OSMC Home Directory

I followed the steps and I got everything as you described. So what am I doing wrong? I see the hard drive on the list provided by windows command line. How can I access it now?

So net view shows the disk? But you can not access it from your Network Neighbourhood?
Maybe try to manually mount it with net use o: \\<IP of OSMC>\<DISK>

Try putting \\<IP of OSMC>\<DISK> in a File Explorer window, NOT Internet Explorer.

The Pi is most likely on the network and sharing but not showing in Network Places in Windows

1 Like

It now appears on the Network. I did nothing to it, Kind of a weird thing to happen, but now I can access it normally. I can access the sd card and the usb drive using samba but only the sd card using the windows explorer for ftp.
Now oher question, what is faster? FTP or Samba? And NFS, how does it work? Do I need to have my laptop on for it to share the files in the network?

EDIT: Now is doesn’t appear again on the Network but is accessible if I manually enter the IP address on the file explorer window, is that normal?

If you’re trying to use files on a device, then that device needs to be on (and on the network).
This behaviour of Windows is a known oddity - it has got worse with later Windows versions.
Derek

It’s now working, just entered the IP on the windows explorer bar and I was able to enter it.

This worked for me. Thank you.

I installed the Samba and can now access the device by entering
\\<IP of OSMC>
into an explorer window.

Unfortunately I can only see the device file structure and not the external drive plugged into the USB.

This just gives an error:
\\<IP of OSMC>\<DISK>

I tried entering the name of the external drive instead of <DISK>

What am I missing or doing wrong?

edit:
I needed to restart the device for it to mount the drive automatically after the SAMBA installation.
Now it appears under windows explorer as expected.