OSMC and tvheadend on separate hardware, sound, but no picture

Yes, MPEG2 is enabled:
osmc@pi:~$ vcgencmd codec_enabled MPG2

OSMC, running on Rpi model B with an HiFiBerrt DAC+:smile:
osmc@pi:~$ uname -a
Linux pi 4.2.1-1-osmc #1 PREEMPT Wed Sep 23 20:52:02 UTC 2015 armv6l GNU/Linux

tvheadend 3.4-1.13.x86_64 running on OpenSUSE 13.2 using a TripleStick USB card with dvb-demod_si2168-02.fw

I can watch TV from any device in the house, but the raspberry. When I hit enter om a TV channel, I get sound and a small “film camera” icon in the lower left corner, rest of menus etc remain. Ie there is no black screen, menus remain.

Before I got the USB stick I played with tvheadend on various hardware and using an older card and got picture. It was horrid though :slight_smile: That was with raspbmc, before I upgraded to OSMC.

Any ideas?

edit: If I record a channel and copy the file to my Raspberry and then browse to that file, the resulting .MKV file plays just fine.

edit: Updated to the latest (OSMC) version and now it works! So either was it the phase of the moon or the update that fixed it.

Please mark your thread as solved. Go to the three dots (show more) and click the tick which will automatically mark it as solved

Done. Sorry about that. Unfamiliar with this particular web interface.