OSMC and TwitchTV

I am a new user to Rpi2 and to OSMC. I have downloaded the alpha 4 a few months ago and everything was working fine - twitch, streaming, youtube. About 2-3 weeks ago my osmc said its not upgradeable, so i “reinstalled” it from my windows PC and set it up again. Everything is again working fine except TwitchTv, loading times are horrible and the video is slow, then fast, then lag, and again in the order, rendering it completely unwatchable. I have tried to google this issue and search this forum, but i had no luck I Am not sure, if i should search for Kodi twitch support, or if that is something different.
I am running my rPi2 over 1000mbit lan with a 120/12 mb connection, connectivity shouldnt be an issue and i stream 720p video from my media center without a problem. I have a 64Gb sd card, but nothing is stored on it except the system. I have made no additional changes. I have NOT yet tried to reinstall. Does anyone know the cause of this issue?
Thank you very much for any help