OSMC and Webcam


I was running Raspbian on Raspberry PI 3 with Kodi 15 as media center.
On Raspbian, I also setted up Transmission and MotionEye with my old USB webcam, Logitech Quickcam Fusion. Everything worked fine.

But I wanted to experience Kodi 17 with something simple and keeping maximum ressources for mediacenter. So I decided to test OSMC that offers exactly what I want (Transmission, Samba, SSH, … and Debian based OS)

I’m now facing a problem, my USB webcam is not recognised by OSMC… :frowning:
It doesn’t appear with ‘lsusb’ command whereas it was OK on Raspbian without doing anything.

Could someone help me (taking account that i’m not a Linux expert… :wink: )
Thanks in advance for your help

Even the ID is not shown? Or just the name missing?
Do you still have the raspian install? Can you share the lsub from the raspian and from OSMC?

Above lsusb form OSMC

osmc@osmc:~$ lsusb
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 005: ID 0480:a00c Toshiba America Info. Systems, Inc.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’m not near my raspberry (I’m at work :wink:), but I still have SD Card with Raspbian. I will send you lsusb from Raspbian tonight.

I precise that devices connected to my Raspberry are :

  • External TOSHIBA HDD 2To
  • Dongle for my wireless keyboard (Logitech K400)
  • Webcam Logitech Quickcam Fusion

Is your powersupply up for the job? Are you using a powered hub for all this?

With Raspbian, 2.5A was enough to power all these devices.
I even tried with a powered usb hub but i have the same issue

I’ve tried again with another powered usb hub and this time it’s working fine !
I don’t understand why a powered usb hud is required with osmc whereas it’s not necessary with raspbian…
But the most important is that I can use at the sametime Kodi and Motioneye.
Thank you for your help.

osmc is rendered with OpenGL ES and uses the Pi’s 3d hardware.
Raspbian doesn’t use the 3d hardware by default.

Thanks for the explanation !