OSMC As a server- USB HDD not visible under SMB


#1

After setting my nfs share with added line in fstab to mount the drive under /mnt, I cannot see my USB HDD attached to Vero 4K, only Vero (osmc home) is visible under my Win10 SMB network.
I tried to share sda4 4TB
blkid
/dev/system: UUID=“scDH4R-CCWx-VQ6d-6x4e-nEYs-3OWW-VdED0e” TYPE=“LVM2_member”
/dev/instaboot: UUID=“XDwmUh-ZZyL-a2lZ-Qeco-YQN1-XaQ8-Caq5wc” TYPE=“LVM2_member”
/dev/cache: UUID=“XLNDzX-H21H-SDH9-IT1V-b4Ki-6Di0-Bm1qC7” TYPE=“LVM2_member”
/dev/data: UUID=“DaDq0s-CoVE-i3LO-jBwp-oE4k-187r-2uZ8Zp” TYPE=“LVM2_member”
/dev/sda2: TYPE=“swap” PARTUUID=“f7882c47-8382-43e2-92fa-bf8638bee6f8”
/dev/sda4: LABEL=“4TB” UUID=“c86e2ee9-fdbd-48ee-a8a1-aceb24d67e9f” TYPE=“ext4” P ARTLABEL=“4TB” PARTUUID=“3fea9b9c-b1e9-4618-bdc7-4326844a1f48”
I wrote a smb-shares.conf with [sharename]
browsable = yes
read only = no
valid users = osmc
path = /mnt/4TB
but that does not work also. What I should write to share my custom SMB share.
Also I have this with :
smbclient -L 192.168.38.69
Enter osmc’s password:
Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    osmc            Disk      OSMC Home Directory
    IPC$            IPC       IPC Service (Samba 4.5.12-Debian)

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Server               Comment
    ---------            -------
    QUADCORE             QUADCORE
    VERO4K               Samba 4.5.12-Debian

    Workgroup            Master
    ---------            -------
    WORKGROUP            VERO4K

Many Thanks
Damir


#2

If you remove the fstab mount and let OSMC mount it under /media, you should see the mount automatically.

Can you confirm this?


#3

Yes If I let automount I can see USB-HDD share in Windows.


#4

I solved it, in smb-shares.conf instead of sharename :slight_smile: it should be 4TB in my case