OSMC as Chromecast receiver on Pi

#1

Hi,
I am trying to get OSMC on Pi 3B+. Both the Pi and OSMC are as latest as available on Octorber 20th 2018.

I want to be able to use Pi to

  1. Be available as a Chromecast receiver such that I can cast from the official Youtube App.
  2. Be able to cast Netflix from netflix app
  3. Be able to cast Amazon Prime from primevideo app

I have spent 2-3 days on this and haven’t been able to get satisfactory results.

As of now I have installed the Youtube script and I can play Youtube videos on Pi . I have also installed Yaste and am able to play Youtube videos on Pi from it. However I can’t seem to get Pi to appear on the official Youtube app as a castable device which is what I really want.

I tried the steps at
https://www.raspberrypi.org/forums/viewtopic.php?t=197143
but libjpeg8-dev libpng12-dev libraries are not available. I’ve installed the alternative to jpeg8 called libjpeg62-turbo-dev but nothing for png

For amazon I have installed the Amazon VOD and I can browse the videos but videos don’t play even though I have installed widevine

Netflix, absolutely no luck.

All information for some reason seems to be from 2017 or early 2018 and all code and module are older! Am I looking at the wrong places and things have changed?

Can someone get me to the latest steps/how to for the above 3 streaming services?

#2
  1. Chromecast is not supported. AFAIK there is no open source library to support it.
  2. Netflix/Amazon VOD is only supported on Leia (Kodi v18) and at least on the Vero4k is limited to 720p (to have a stutter-free experience); no experience on RPI3. Are you running the correct version?
#3

If i gathered your question you want the whole chromecast experience??

The solution you mention for youtube isn’t really chromecasting, it’s pi casting.

You will have to settle for other solutions, the reason for this is that chromecast is propitiatory software/hardware and demands that the clients using it (netflix, amazon, spotify etc etc) to pay a a bit to be able to use casting to chromecast.

With software which is opensource you will likely never get chromecast support, and for a device to be supporting chromecasting unless it’s googles.

There are as @nrosier said solutions for running those in Kodi, running Leia you can run addons for Amazon, netflix, youtube, viaplay. But they wont have the bells and whistles that the android apps for the same services has.

For running Netflix under Kodi 18 you got a guide here on the forum, search netflix and thefirst result should be the guide.

1 Like
#4

I’ve not used it, but I believe there’s a Kodi add-on called TubeCast which allows you to cast to the Kodi YouTube add-on: https://kodi.tv/addon/scripts/tubecast

As others have already said, the performance you can get out of Netflix under OSMC probably isn’t good enough to bother with.

Any reason why you can’t just buy a Chromecast? :slight_smile: They’re not very expensive.

#5

Yatse on Android gives the ability to cast YouTube vid from the YouTube app to any Kodi device.

1 Like
#6

This worked! Simplest thing on earth! Thank You @angry.sardine.

I do have a Chromecast on a TV and I could buy another one or Firestick but PI3+ is so much better because I can connect my external HDD to the USB ports, run it as an SMB server, play media from them, run myraid of apps on it and in the future develop some hardware to turn on or off the power to the HDDs by remote control, etc. etc. etc. I could do some of these on my NAS drive but it crashed recently and it could not connect my non NAS HDD to the network. RPI can do everything because it’s an always on tiny computer!

#7

That’s a great way to shorten the life of the drive.

Bear in mind as well that even an RPi 3B+ is limited to network speeds of around 320Mb/s. That’s not an issue for streaming - it’s two or three times as much as you need to stream a 4K video - but it will slow you down when you’re copying files across the network.

I hear you, but both the RPi and a Chromecast are cheap enough that there’s no reason why you can’t buy both. :slight_smile:

#8

Okay my happiness was short lived :frowning: Today OSMC decided to get upgraded and once it got upgraded Tubecast no longer seems to work correctly. Every time I go to programs and click on Tubecast, it starts pairing process with YouTube also it is no longer seen on official YouTube app for casting :slightly_frowning_face:

I’ve uninstalled both Youtube as well as well as Tubecast add ons including deleting settings. Reinstalled YouTube and Tubecast but this made no difference.

Further I’ve noticed that my iPhone 5s with updated Youtube app still connects, this was the device I used in the first place, however my Android phone with Youtube does not see the RP/Tubecast. I disconnected the 5s and tried the Android but still no effect. With the 5s now even though I can connect, playing any video crashes the RP and I see the frowning face icon on a blue screen.

#9

Rpi3b ethernet speed is limited to 10MB/s

I go to kodi repository install youtube from there and use yatse from my phone

I remember people using chromium for netflix but performance was awful.

#10

Can you give instructions on how to do this?

Thanks

#11

Connect Yatse to your Kodi installation. Then use the YouTube app on the phone, find the video and use the share icon to “play on mediacenter” with the yatse icon.

1 Like
#12

If you received an update today means you are on Staging or Testing. So things may break from time to time so the addon might be working after next update.

#13

When you’ve got the Yatse add-on installed you can even send pretty much any video URL for playback… :+1:t2:

#14

OSMC seems to break Tubecast everytime. Tubecast is out of order.

Round about 4 months ago SSDP (Device Discovery) stopped working (but the manual option worked somethines [connection via a TV-code])

2 months ago the TV-code method stopped too. I waited for an update to fix this issue, but every update just dont “repair” the addon. (Addon works tested on different machine with windows)

Is there a way to fix this?
Or do i have to switch to LibreELEC and rip the OSMC skin?

Don’t want to use everytime a second app only to cast (like Yatse) and need the multi/-crossuser-playlist option in tubecast.

#15

Have you tried contacting the Tubecast developers? That’s probably the best place to start.