OSMC Backup hangs on “Transferring” despite it completing

I have configured backups to go to my NAS Drive (permissions all seem fine) via the My OSMC app.

However, recently I’ve noticed that the notification on screen remains as “Transferring” even though it appears to have completed. I say this because I checked the .zip file on my NAS and the file size remained static (at 2.06GB) for several minutes, as I would expect the file size to increase with every refresh if ther transfer was still in progress.

If I then attempt to watch a TV show or movie, the Vero freezes. I cannot even SSH into the device to reboot via the command line, so I have to physically unplug it, which I hate doing.

My logfile after the latest crash is here: https://paste.osmc.tv/anemiwugehv.

This has happened at least three times recently, hence why I’m logging it here. Could this be a bug @sam_nazarko?

I didn’t know we supported backing up to network.

CC @Karnage

You can choose the location via the backup option within the updates section of the My OSMC app.

I used to use the Backup addon to do this, but the functionality is identical to within My OSMC so figured I’d use that instead.

Hope that helps.

There may be some local issue for you there. I’ve just completed a backup to an NFS share and it completed without issue. Maybe we’ll see something in your logs. You have confirmed no storage space issues on the NAS or the V4K?

I routinely do both the OSMC backup and the Backup utility to a network share via NFS. Did one yesterday as a matter of fact and it went without a hitch. That was after the March update as well.

Hmm, ok. Maybe it’s not a bug then. There are no issues on either the NAS or Vero either. I’ll try again, but it’s odd that it’s happened a few times to me recently.

How big are your backups?

I wonder if @raspberrycoulis is running out of space. We archive it locally first before transferring to the destination

Yes Sam this could be the issue. I don’t backup thumbnails as they can be a huge addition to the archive size. Without thumbs I’m aprox 450MB in size zipped.

They are 2.06GB as I include the Addons folder too (not thumbnails though). I’ve just set the options back to default and re-added the remote share for my NAS and it worked. Sorry for the waste of time, but the suggestions seemed to have helped fix this.

Glad you sorted it out pal.

Actually… Just tried to redo a backup with the addons folder included and it says “Insufficient diskspace at target location” but the NAS Drive has 200GB+ free on the volume I’ve chosen…

Maybe there isn’t enough space locally initially as @sam_nazarko suggested?

EDIT: My system info shows 13GB free on /dev/vero-nand/root so this is strange…

Can we see df -h please?

There you go.

Read your /dev/vero-nand/root line again :wink:

1 Like

What a dumbass! :man_facepalming:t3:

I could have sworn it was the opposite way around within the system info on OSMC!

Better start some housekeeping…

EDIT: Any ideas what to do to free up some space here?

13gb in use seems awfully high. Do you have a ton of add-ons? There is less than 5% free space in the root directory. This in itself could cause all kinds of issues, not just backup related.

No I don’t. That’s what’s strange. I have a few, but noting huge. I’ll have a look through and see what I can get rid of - I suspect it could be the Apple TV Aerial screensaver videos…

du -cks * | sort -rn | head

Keep following into the largest directory. You’ll find the culprit.

1 Like

Found it. There were 4 zipped backup files in the .kodi/temp folder. Removed them and have 9.0G available again now! Thanks!

Assumed they didn’t transfer properly so just stayed there! It would be great if they were removed on reboot if they didn’t transfer successfully, but at least I know where they are now.


1 Like