OSMC blocked on boot

Hi all,

Let me start by wishing you all the best for this holiday season!

I’ve just installed OSMC on my new Raspberry Pi 4 and am facing the following message on boot: “Started update UTMP about System Runlevel Changes”.

Here is my config and latest actions:

  • Dual boot with OSMC+Recalbox using PINN lite (using this tuto: Recalbox & Kodi Dual Boot for Raspberry Pi)
  • OSMC backup loaded from my previous OSMC/RPi3
  • Kodi backup loaded from my previous OSMC/RPi3/Kodi
  • configuring my Logitech Harmony remote on bluetooth
  • connecting Xbox playing remote adapter

Here is my log: https://paste.osmc.tv/esinexipat
I can see several warnings but I’m a big noob…
Mesa warning: failed to remap glGetInteger64v
(and several more like that!)

I can log in to the Rpi using SSH.
When I try to just “reboot”, it does the same (blocking on boot).
I succeeded in starting Kodi by unpluging power supply, but it seems there are connection issues (remote doesn’t work and wifi seems to disconnect some times).

I tried to reboot with my external hard drive unpluged, and it seems to work fine.
Here is the log: https://paste.osmc.tv/ijumutisux
I tried to reboot several times without the HD, and it keeps working.
The remote (bluetooth) is working well and wifi seems to be stable.
The HD is a WesternDigital with external power supply.

I looked for a similar issue in the forum but didn’t find the same “warnings”.
Thanks for your help!

Have you tried using a stock OSMC image?
I believe PINN uses a shared kernel for all images, which isn’t supported.

Hi sam_nazarko
I would like to keep having OSMC+Recalbox on a dual boot. Is it possible with your suggestion?
Not sure I get it.

Unfortunately we don’t support PINN. My understanding is that it makes changes to the operating system which are not supported. You may prefer a NOOBS installation.

Ok thanks
But do you think my issue might be related to PINN vs NOOBS? As I told, it seems everything is working well when I unplugged the hard drive. It also works when I plug the HD back after a clean start…