OSMC Branded 5GHz WiFi Stopped Working


#1

Hi,

My OSMC 5GHz WiFi card has stopped working on my Vero2. I can see 5GHz networks in the network list in OSMC, but when I click to connect on one nothing happens.

I have searched the forum and all the solutions seem to reference a kernel rebuild for Pi, which obviously isn’t relevant to me.

lsusb shows:

osmc@VERO2OSMC:~$ lsusb
Bus 001 Device 003: ID 04d9:2519 Holtek Semiconductor, Inc. Shenzhen LogoTech 2.4GHz receiver
Bus 001 Device 005: ID 0e8d:7610 MediaTek Inc.
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
osmc@VERO2OSMC:~$

If I look at dmesg after plugging the dongle in it says the below, which seems to indicate a number of driver failures:

[1117243.970579] usb 1-1.1: new high-speed USB device number 5 using dwc_otg
[1117244.086918] usb 1-1.1: New USB device found, idVendor=0e8d, idProduct=7610
[1117244.086934] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3[1117244.086943] usb 1-1.1: Product: WiFi
[1117244.086951] usb 1-1.1: Manufacturer: MediaTek
[1117244.086958] usb 1-1.1: SerialNumber: 1.0
[1117244.088141]

                 === pAd = f0ce0000, size = 857568 ===

[1117244.088188] <-- RTMPAllocTxRxRingMemory, Status=0
[1117244.088661] <-- RTMPAllocAdapterBlock, Status=0
[1117244.089064] ==>RT65xx_WLAN_ChipOnOff(): OnOff:1, Reset= 0, pAd->WlanFunCtrl:0x0, Reg-WlanFunCtrl=0xff000002
[1117244.095780] MCUType = 2
[1117244.096269] NVM is EFUSE
[1117244.096278] Endpoint(8) is for In-band Command
[1117244.096284] Endpoint(4) is for WMM0 AC0
[1117244.096289] Endpoint(5) is for WMM0 AC1
[1117244.096295] Endpoint(6) is for WMM0 AC2
[1117244.096300] Endpoint(7) is for WMM0 AC3
[1117244.096305] Endpoint(9) is for WMM1 AC0
[1117244.096310] Endpoint(84) is for Data-In
[1117244.096315] Endpoint(85) is for Command Rsp
[1117244.104931] -->RTUSBVenderReset
[1117244.105060] <--RTUSBVenderReset
[1117244.110070] fw version:0.1.00 build:7640
[1117244.110083] OSMC firmware date:201308221655____
[1117244.110103] ilm length = 68780(bytes)
[1117244.110110] dlm length = 11476(bytes)
[1117244.130379] #
[1117244.137291] loading fw......
[1117244.210367] #
[1117244.441051] RTMP_TimerListAdd: add timer obj f0d5eb84!
[1117244.441068] RTMP_TimerListAdd: add timer obj f0d5ebcc!
[1117244.441075] RTMP_TimerListAdd: add timer obj f0d5ec14!
[1117244.441082] RTMP_TimerListAdd: add timer obj f0d5eb3c!
[1117244.441091] RTMP_TimerListAdd: add timer obj f0d5ea64!
[1117244.441106] RTMP_TimerListAdd: add timer obj f0d5eaac!
[1117244.441113] RTMP_TimerListAdd: add timer obj f0cf2c2c!
[1117244.441120] RTMP_TimerListAdd: add timer obj f0ce203c!
[1117244.441126] RTMP_TimerListAdd: add timer obj f0ce2088!
[1117244.441133] RTMP_TimerListAdd: add timer obj f0cf2d14!
[1117244.441141] RTMP_TimerListAdd: add timer obj f0cf2b9c!
[1117244.441150] RTMP_TimerListAdd: add timer obj f0cf2ccc!
[1117244.441166] Loading default parameter profile
[1117244.441177] cfg_mode=12
[1117244.441186] wmode_band_equal(): Band Not Equal!
[1117244.441421] cfg_mode=8
[1117244.441430] wmode_band_equal(): Band Not Equal!
[1117244.441895] Key1Str is Invalid key length(0) or Type(0)
[1117244.441943] Key2Str is Invalid key length(0) or Type(0)
[1117244.441996] Key3Str is Invalid key length(0) or Type(0)
[1117244.442044] Key4Str is Invalid key length(0) or Type(0)
[1117244.442955] 1. Phy Mode = 17
[1117244.442962] 2. Phy Mode = 17
[1117244.442975] NVM is Efuse and its size =1d[1e0-1fc]
[1117244.476391] /mnt/package/kernel-osmc/src/vero2-linux-master/drivers/net/wireless/mt7610u/os/linux/../../chips/mt76x0.c:2114 assert (pAd->TxPower[choffset].Channel == 36)failed
[1117244.505644] ERROR!!! E2PROM: WRONG VERSION 0x2, should be 1
[1117244.517152] mt76x0_read_tx_alc_info_from_eeprom: EEPROM_MT76x0_TEMPERATURE_OFFSET (0xD1) = 0xfb
[1117244.517166] mt76x0_read_tx_alc_info_from_eeprom: TemperatureOffset = 0xfffffffb[1117244.517172] Temperature Tx ALC not enabled
[1117244.557660] 3. Phy Mode = 17
[1117244.557676] AntCfgInit: primary/secondary ant 0/1
[1117244.563685] RTMPSetPhyMode: channel is out of range, use first channel=36
[1117244.566676] MCS Set = ff 00 00 00 01
[1117244.576535] <==== rt28xx_init, Status=0
[1117244.578674] 0x1300 = 00064300
[1117244.578685] RTMPDrvSTAOpen(1):Check if PDMA is idle!
[1117244.579057] RTMPDrvSTAOpen(2):Check if PDMA is idle!
[1117244.656702] /mnt/package/kernel-osmc/src/vero2-linux-master/drivers/net/wireless/mt7610u/os/linux/../../common/cmm_asic.c:2112 assert KeyIdx < 4failed
[1117244.657572] /mnt/package/kernel-osmc/src/vero2-linux-master/drivers/net/wireless/mt7610u/os/linux/../../common/cmm_asic.c:2112 assert KeyIdx < 4failed
[1117248.935322] ===>rt_ioctl_giwscan. 1(1) BSS returned, data->length = 202
[1117261.206692] ===>rt_ioctl_giwscan. 1(1) BSS returned, data->length = 202

Any ideas anyone?

Regards,

Tony


#2

Full logs would be best. I see you’ve run lsusb and dmesg, so grab-logs -A is probably easiest for you.

The OSMC WiFi dongle should have a configuration file in /lib/firmware that might have been overwritten or become corrupted. What’s the output from running

find /lib/firmware -name mt7610u_sta\* -ls

#3

Indeed. It may also be worth purging network definitions from /var/lib/connman/wifi_*


#4

@sam_nazarko, there were two entries in the directory, so I purged them:

osmc@VERO2OSMC:/var/lib/connman$ ls
ethernet_086160112334_cable
settings
wifi_000000000000_546f6e79574c414e5f35_managed_psk
wifi_34c3d23282d8_546f6e79574c414e5f322e34_managed_psk
osmc@VERO2OSMC:/var/lib/connman$ sudo rm -rf wifi_*
osmc@VERO2OSMC:/var/lib/connman$ ls
ethernet_086160112334_cable  settings

@dillthedog, here is the output of find:

osmc@VERO2OSMC:/var/lib/connman$ find /lib/firmware -name mt7610u_sta\* -ls
   258863      4 -rw-r--r--   1 root     root         1271 May  2  2016 /lib/firmware/mt7610u_sta.dat
   258719      4 -rw-r--r--   1 root     root         1271 Nov 22 06:53 /lib/firmware/mt7610u_sta.template.dat

I ran grab-logs without the OSMC 5MHz dongle attached, then plugged it in, then ran grab-logs again:

Note that behaviour remains the same (ie in the OSMC GUI the 5MHz connections show as available, but when I ‘click’ on them nothing happens - whereas if I ‘click’ 2.4MHz connections I am prompted to connect).

Regards,

Tony


#5

For info, the 5GHz WiFi settings (I have several other devices that are attached successfully to this network):

Untitled


#6

Having purged the old connman WiFi entries you need to reboot the device with the dongle installed.

The log shows that you were already connected on 2.4 GHz when you plugged in the dongle.

Apr 27 18:56:57 VERO2OSMC wpa_supplicant[433]: wlan0: Trying to associate with 10:6f:3f:7f:47:58 (SSID='TonyWLAN_2.4' freq=2462 MHz)
...
Apr 27 18:56:58 VERO2OSMC wpa_supplicant[433]: wlan0: WPA: Key negotiation completed with 10:6f:3f:7f:47:58 [PTK=CCMP GTK=CCMP]
Apr 27 18:56:58 VERO2OSMC wpa_supplicant[433]: wlan0: CTRL-EVENT-CONNECTED - Connection to 10:6f:3f:7f:47:58 completed [id=0 id_str=]
...
Apr 27 18:56:58 VERO2OSMC avahi-daemon[294]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.49.

#7

I have rebooted the Vero2, but the same behaviour persists (ie in the OSMC GUI the 5MHz connections show as available, but when I ‘click’ on them nothing happens - whereas if I ‘click’ 2.4MHz connections I am prompted to connect)

/var/lib/connman contains the below, reflecting the 2.4GHz connection that I have made that you mention above:

osmc@VERO2OSMC:/var/lib/connman$ ls
ethernet_086160112334_cable
settings
wifi_34c3d23282d8_546f6e79574c414e5f322e34_managed_psk

#8

34:c3:d2:32:82:d8 is not the MAC address of the dongle, which is 7C:DD:90:B7:69:F2, so that connection is being made using the internal WiFi.

You probably need to disable the internal WiFi. According to this post, you should add the line blacklist r8189es to file /etc/modules, though I can see no mention of r8189* in the log. Perhaps @sam_nazarko can advise.

Edit: I read to the end of the thread and r8189es was a typo by Sam. The line should be blacklist 8189es.


#9

I’m afraid that this has had no effect. I have rebooted the Vero twice and both times the internal WiFi connects, and when I click in the UI on the 5GHz item nothing happens. File contents below:

osmc@VERO2OSMC:/etc$ cat modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

#added to disable internal WiF, so external dongle will be used
blacklist 8189es

#10

Perhaps the driver has changed. What’s the output from lsmod.


#11

Output is:

osmc@VERO2OSMC:/etc$ lsmod
Module                  Size  Used by
cbc                     2030  0
iptable_nat             1956  0
nf_conntrack_ipv4       6263  1
nf_defrag_ipv4           901  1 nf_conntrack_ipv4
nf_nat_ipv4             2702  1 iptable_nat
nf_nat                 11071  2 nf_nat_ipv4,iptable_nat
nf_conntrack           44641  4 nf_nat,nf_nat_ipv4,iptable_nat,nf_conntrack_ipv4
iptable_filter          1053  0
ir_rc5_decoder          1325  0
ir_lirc_codec           3714  3
lirc_dev                7676  1 ir_lirc_codec
ir_sony_decoder         1407  0
ir_sanyo_decoder        1385  0
ir_mce_kbd_decoder      2731  0
ir_jvc_decoder          1373  0
mali                  160439  5
ir_nec_decoder          1525  0
meson_ir                2503  0
rc_core                10851  9 meson_ir,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_jvc_decoder,ir_sanyo_decoder
am_net8218_osmc        31780  0
mt7610u_sta           787693  1
8189es                810267  0
cfg80211              184450  1 8189es
ip_tables               9445  2 iptable_filter,iptable_nat
x_tables               11610  2 ip_tables,iptable_filter

#12

I think Sam might have erred with his post.

If one doesn’t already exist, create a file /etc/modprobe.d/blacklist.conf and insert the line blacklist 8189es into it. Remove the line from /etc/modules. Then reboot. Check if it’s working correctly with lsmod.


#13

@dillthedog, this seems to have (at least partially) nailed it. After rebooting only 5GHz networks showed in the UI, and when a 5GHz network was clicked I was correctly prompted to enter a password, and am now connected to my 5GHz network.

This is reflected in the connman directory - but interesting that the MAC shows as 00:00:00:00:00:00 :

osmc@VERO2OSMC:~$ ls /var/lib/connman
ethernet_086160112334_cable
settings
wifi_000000000000_546f6e79574c414e5f35_managed_psk
wifi_34c3d23282d8_546f6e79574c414e5f322e34_managed_psk

For info, lsmod shows:

osmc@VERO2OSMC:~$ lsmod
Module                  Size  Used by
cbc                     2030  0
iptable_nat             1956  0
nf_conntrack_ipv4       6263  1
nf_defrag_ipv4           901  1 nf_conntrack_ipv4
nf_nat_ipv4             2702  1 iptable_nat
nf_nat                 11071  2 nf_nat_ipv4,iptable_nat
nf_conntrack           44641  4 nf_nat,nf_nat_ipv4,iptable_nat,nf_conntrack_ipv4
iptable_filter          1053  0
mt7610u_sta           787693  1
ir_lirc_codec           3714  3
lirc_dev                7676  1 ir_lirc_codec
mali                  160439  5
ir_sony_decoder         1407  0
ir_sanyo_decoder        1385  0
ir_mce_kbd_decoder      2731  0
ir_jvc_decoder          1373  0
ir_nec_decoder          1525  0
ir_rc5_decoder          1325  0
meson_ir                2503  0
rc_core                10851  9 meson_ir,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_jvc_decoder,ir_sanyo_decoder
am_net8218_osmc        31780  0
ip_tables               9445  2 iptable_filter,iptable_nat
x_tables               11610  2 ip_tables,iptable_filter

It’s a bit of a pain that I’ll have to (remember to!) mess with /etc/modprobe.d/blacklist.conf if I want to go back to 2.4GHz, but at least now I have the option of both network frequencies to play with!!.

Music steaming smoothly as I type…

Thanks for your help!

Tony


#14

The OSMC dongle will also be able to connect to the 2.4GHz network


#15

The OSMC dongle will also be able to connect to the 2.4GHz network

I’m afraid that only 5GHz networks are now shown in the GUI. The long list of 2.4GHz networks are no longer shown.


#16

Thats odd, mine shows both networks.
Maybe you need to play around with the config file. But for the time being enjoy the 5GHz