OSMC broken after TV being off

All due respect Sam, this has been going on for long enough now. Saying that there will be a fix coming as part of Isengard, when Isengard doesn’t even have a release date is simply not good enough, is insulting and borderline offensive. We’ve been waiting patiently for the product that we bought to become functional. It’s time for you guys to show you care. If there’s a fix - put it out.

We can only push this fix out with Isengard, because the kernel is very closely coupled with Kodi itself. It’s just around the corner.

Thanks for your patience

Sam

1 Like

@sam_nazarko Hi Sam, was this supposed to be fixed in the most recent release? If so it still isn’t working. I just updated and the same problem occurs.

Yes, the problem should be fixed now.

Please verify you are indeed up to date (output of uname -a should be 4.1.3) and Kodi should show a compilation date of at least 3rd August.

Failing that, we’ll need a log to see what’s happening

Sam

@sam_nazarko yep:Linux osmc 4.1.3-7-osmc #1 SMP PREEMPT Sun Aug 2 17:55:40 UTC 2015 armv7l GNU/Linux

How do I upload a log? Is there an instruction anywhere?

https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507/1

@ActionA thanks
@sam_nazarko

Device: Vero
Installation media: SDcard
Connection: Wired
Power Supply Type: Standard that ships with Vero
Power specs:
Peripherals: USB Hard Disk
Storage Device USB Hard Disk
OSMC version: VERSION_ID=“2015.07-1”
XBMC version: 15:38:34 T:1955782656 NOTICE: Starting Kodi (15.1-RC1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
15:38:34 T:1955782656 NOTICE: Using Release Kodi x32 build (version for Vero)
Codecs: n/a
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras: n/a

http://paste.osmc.io/ajutitijez

Vero connects to Surround Sound Receiver via HDMI. Receiver connects to TV through HDMI.
Receiver has a video passthrough which passes through the output when in standby but this same problem occurs when the receiver is on. The logs are for when the receiver is in standby.

Steps to reproduce:
Turn Vero on and have it recognise the TV as 1080p
Turn the TV off.
Turn the TV on again
Vero reverts to 720p
Play a film in 1080p
Vero is now set to 1080p.

The Kodi.log shows these steps from 16:22 onwards (line 3259 is me turning on logging).

Sam,

It is incredibly frustrating to see you proclaim that “the problem should be fixed now”. By my count, this is the third time you’ve said this, only to then declare that the problem will be fixed at some later date. Who are you checking with to see if the problem has been fixed? Certainly not any of the people who actually experienced the problem, as I’ve not seen a single one of them confirm that any such thing has happened.
To be clear - THE PROBLEM HAS NOT BEEN FIXED. And yes - I’ve updated to the absolute latest version (output of uname -a is 4.1.3, etc.)
Now instead of trying to placate us and send us off in search of additional logs, can you please come up with some other mechanism to try to understand what is going on here and fix it once and for all? Don’t we deserve this by now?

There have been three major issues with HDMI connectivity that were addressed in this update:

  • The picture not coming back after HDMI being removed / TV turned off
  • A slow GUI after the picture comes back when HDMI is removed / TV is turned off
  • The GUI coming back after HDMI is removed / TV is turned off, but with the wrong resolution.

I haven’t seen any logs from you. I made the reasonable assumption that with the above three issues fixed, we should have fixed most users display issues, and that any new ones will require a log to explore what is going on.

Similar symptoms do not necessarily equate to the same problem.

Sam

1 Like

@sam_nazarko hi sam, have you managed to look at the logs I uploaded? I share @yrvero 's frustrations. The most frustrating thing is that Raspbmc worked fine with the exact same setup but cost a quarter of the price. I’m willing to help where I can with this so please let me know if there is any further information you need.

Hi sonnyikea

Your links are not loading for me, but a fresh set is needed nonetheless. There have been some changes in the windowing code (which is why some of the display issues have been fixed). Fresh logs will be needed.

Sam

@sam_nazarko how about this link?

http://paste.osmc.io/apetiraces

Fair enough.
Here’s all the information you could every want:

Device: Vero
Installation media: SDcard
Connection: Wired
Power Supply Type: Supplied
Power specs:
Peripherals: Pioneer receiver
Storage Device NFS
OSMC version: 2015.07-1
XBMC version:
Codecs:
Audio/Video Output: HDMI
Overclocked: No

Description:
Vero is connected to a Pioneer receiver via HDMI and receiver is connected to a Pioneer TV. When the Vero is set to 1080p and the TV and/or Receiver (either one) is turned off and then back on, the picture that appears on the TV is garbled. Notes:

  1. The vero video output menu shows two options for 1080p – one at the top of the menu and one towards the bottom. The problem occurs no matter which one has been selected.
  2. If any other resolution is selected prior to turning the TV off (e.g. 720p) the problem does not occur.
  3. When the problem occurs, if I go into the video output setting (by memorizing the necessary steps, as the picture itself is garbled) and select another output resolution, the problem goes away. If I then reselect 1080p, the picture is fine.
  4. When the problem occurs, if I reset the Vero, either by memorizing the steps necessary or by pulling and re-inserting the plug, the problem goes away.
  5. I have a Raspbmc and a Windows-based Kodi both connected via the exact same setup. Neither has this problem – only the Vero does.
  6. Connecting the TV directly to the Vero (without the receiver in between) does not solve the problem.
  7. Sometime, if the TV has been off for only a short while, when it is turned back on the problem doesn’t occur.

logfile uploaded to: http://paste.osmc.io/afubedepes

Please note that I cannot use the built-in logfile upload as I can’t see anything on the screen when recreating the problem (which is the whole issue), so I used ssh to manually upload the logfile. If this is not the file you want, then please tell me EXACTLY what you need and how to ssh for it.

Also, I PROMISE I’ll let you know the second the problem is resolved. If I haven’t, you can safely assume that it still exists…

regards,
Yoram.

Hi

This is only a Kodi log. It would be good to get some other logs too. I understand you have no picture, but you can grab them via SSH:

sudo journalctl | paste-log

dmesg | paste-log

There may be one more log needed after that but should give me enough to take a look.

Sam

Hi,

Here are my logs: http://paste.osmc.io/oyejeletij

I got them as follows:

  1. enabled debugging
  2. shut down tv and amp for couple of hours
  3. put tv and amp back on -> this time no signal, not the distorted 720p
  4. waited ~10minutes and the signal got back with flickering colorful noise
  5. in couple of minutes tried to use the device, but it was frozen, remote or keyboard didn’t work and the debug data on the screen was frozen also
  6. unpluged and plugged in the power
  7. started up normally
  8. exported logs

I can export logs when the device gives distored signal also. Should I export it through ssh or just reboot and export after that?

@sam_nazarko Sam, can you read my logs?

Here you go:

http://paste.osmc.io/ikarunewap

http://paste.osmc.io/coqicisogi

And just to be 100% precise - It’s not that “I have no picture”. There is a picture on the screen, it’s just completely messed up and garbled.

@sam_nazarko any news? Did any of the logs that we uploaded help?

I may have a build for you to try over the weekend.

Sam

great, thanks.