OSMC BT dongle doesnt find headphones

I have a Raspberry pi 3 running the latest Kodi v17.6. I have also just received the OSMC BT dongle. Without the dongle the pi finds my headphones but connection fails. I hoped that the dongle would resolve this but it doesn’t. I have disabled the pi’s internal BT by adding ‘dtoverlay=pi3-disable-bt’ in the config file but then the dongle doesn’t find anything. At least the internal BT found my headphones, Iphone and sound system. So Im wondering if it is the dongle that is a fault or if I’m doing something wrong although the dongle does light up red so it does seem to be working.

To start: did you install the A2DP package?

oops sorry, I didn’t realise I had to do that with with the OSMC dongle and latest update. I will give it a go thanks

I have tried installing the A2DP package using my iMac but after it runs I get this:

0 upgraded, 62 newly installed, 0 to remove and 1 not upgraded.
Need to get 14.4 MB of archives.
After this operation, 34.0 MB of additional disk space will be used.
Do you want to continue? [Y/n]

When I hit Y or any other letter including Yes it just aborts. So i have tried using my sons Windows laptop and the same happens. I cant get the package to install. I’m at a loss and beginning to pull my hair out (what I have left anyway)

As ‘Y’ is the default answer, did try to just hit the ‘Enter’ key ?

Yes, I tried that as well as every letter in the alphabet as I noticed on some Ubuntu forums that it could be an ‘o’ for the French Oui or ‘s’ for the Spanish Si but still no success