OSMC build Aug 2021 tvheadend client issues

Hi all,

I’m having an issue with tvh client running on rpi4 and osmc build Aug 2021 (fresh install on sdcard).
The problem is in preview (smaller video in channel list). Once I select a channel video is “flickering” like the refresh rate is wrong (like when you record the monitor with camera, horizontal lines, like it’s flashing). If I switch to full screen there is no issue and everything is working fine.
Has anyone experienced this issue?
I’ve tried enabling half / double refresh rates, changing UI resolution and things like that with no luck. If you need video as a proof or logs let me know.
The PI is connected directly to LG CX.

Best regards.

TBH, I didn’t know that was supported. Full debug logs would be useful.


Sorry for my late response.
You can find the log here
It’s debug log from clean boot.
The first channel that I’ve tried after boot did not display any image with the debug enabled, but the second one did.
Also, some more info:
skin: confluence
audio: passthrough (Q900A)
connections: pi is connected to CX, soundbar uses eARC
CX firmware is the latest version available
I’ve tried connecting the pi to soundbar but then I get black screen every few seconds.
What I mean by “smaller video in channel list” is once you open the channel list and have switch to full screen disabled it will start the playback on the top right.

Can’t think of anything else useful to add. If you need any more info just let me know and I’ll provide them.

some additional info:

If I disable PRIME render - all is good
If I enable PRIME, (either with HW accel or without and either with only allow accel for HEVC ) - not good
If I enable PRIME and set render method to EGL - all is good

settings - player - adjust display refresh rate - on start / stop
settings - system - refresh rate 60

But with EGL UHD is not working for me
2021-11-17 21:17:56.757 T:23277 INFO : GLES: Selecting single pass rendering
2021-11-17 21:17:56.758 T:23277 INFO : GLES: Selecting YUV 2 RGB shader
2021-11-17 21:17:56.758 T:23277 ERROR : CBaseRenderer::GetShaderFormat - unsupported format 182
2021-11-17 21:17:56.758 T:23277 ERROR : GLES: BaseYUV2RGBGLSLShader - unsupported format 0

@grahamh have you had a chance to look at this issue or du you need any aditional information?

Those aren’t full logs, so unfortunately we cannot advise.

Hi @sam_nazarko ,

Here is the new log.
Done today (enable debug, reboot two times then did the test).
If PRIME is disabled or if EGL is selected it’s working
I had to remove lines regarding epg and channels due to pastebin size limitations for non-registered users, sorry about that.
If needed, I can try and use osmc log uploader next time if these logs are not good.

Sorry, but we normally expect a log set uploaded to the special servers and by this you don’t have to manipulate the logs. Here again the instructions hwo to collect the data we expect in case this is not known:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Yeah, okay, no problem at all.
You can find the logs at here

I have the same problem since the august update. If you need more logs let me know.

The flickering is more noticeable in person, but it’s possible to see the preview is flickering in this video.

I’ve updated to the latest stable and the issue is still present. I’ve also noticed that once you go to full screen and hit back button to show the channels, the video is not scaled down to fit the smaller frame, it’s cropped.

Hi guys, is there any update on this one? If you need I can create you an account on tvh server so that you can test.
Thanks in advance

This might be best reported upstream to Raspberry Pi developers.
It’s not something we have much control over.