OSMC-Buster-RPI-1 Missing one IR command

I have an old RPI-1 running OSMC as a Mythtv Frontend. I recently tried updating it to “Buster”.

It all worked except for one reason, one button on my IR remote control no longer works (the rest do, and it used to work).

My remote is and old Western-Digital “live” remote and I am just using the lircd.conf file that already exists for it (and the same one worked previously). The key that does not work anymore is the “OK” key.

In “mode2” I get numbers when I push the button. On IRW (which was looking in the wrong place for the pipe file by default), it doesn’t. Other buttons produce correct commands. The version of lirc that is running is coming from OSMC’s repository. I get lots of dependency problems if I try to install Raspian Buster’s 0.10 version. I have an RPI-4 running Debian Buster-64bit with the 0.10 version of lirc and it works too (running Myth Frontend, not OSMC).

I can put in my old “Stretch” version of OSMC into the same hardware and all works fine. (lirc ver: 0.9.0).

I can’t figure out what would make just one button not work!

I’d recommend waiting until the official Buster repository is ready, then testing again


Same here (RPI-2). But quite a few keys dont work anymore.

Workaround til the official update:
I downgraded only the package armv7-lirc-osmc to the version from stretch and everything works…


Are you using the OSMC Buster repository?

Yes: deb http://apt.osmc.tv buster main
I even tried to nail it down a bit by comparing 0.9.0-6 (stretch) and 0.9.4-3 (buster) of armv7-lirc-osmc.
But i had to give up, cause the new one is 6 times the size of the old one and of a rather different inner structure (e.g. /usr/var/run/lirc instead of /var/run/lirc and so on)?!


Okay, will look in to it.

I’m still on this forum too, in case any real-world testing needs to be done.

I bumped the LIRC version to resolve some compilation issues, but this might have caused some regression.

Thanks for thinking about this, I’ll watch for any changes you might push out.

Otherwise the OSMC Buster appears to work fine for me on my original RPI-1, but then I only run the Mythtv TV-PVR client on it as it just barely has enough memory to run this and nothing else (This is the old 256M version RPI!). In fact I had to set 128M of swap space and ended up with these sysctl settings:

vm.dirty_expire_centisecs = 1000
vm.dirty_writeback_centisecs = 1500

for reasonable 1080p HDMI playback of MPEG ATSC Video (with the optional license of course, which is why I’m still using this old RPI). After it initially swaps out much of Kodi upon startup, I don’t seem to get too much swapping after that in normal use (as in I’ve had this setup running on the same old 2-GB SD card over 5 years now and it hasn’t died yet!).

I did have to manually install/reinstall the libmariadb package for Kodi to have it’s dependencies satisfied at run time with this MythTV TV-PVR client installed however. The package manager didn’t catch this alone.


I fixed this a while ago but only pushed the changes recently.

Still looking in to the LIRC issue.



We’ve looked in to this and can’t reproduce an issue with OSMC on Debian Buster. This was tested with an Xbox 360 IR remote on Vero 4K/4K+. This suggests this might be specific to something on Pi or the LIRC configuration that you are using; but the actual paths and LIRC setup on OSMC seem to be OK.

Please post the output of:
dpkg -l | grep lirc

Are you sure you haven’t installed the regular Debian/Raspbian ‘lirc’ package ? On OSMC we use a custom version of lirc in a package such as rbp-lirc-osmc, however the Debian lirc package is still available in the repository and could be accidentally installed. It’s very likely it uses different paths than our version and should not be installed.

Sorry, i missed the question…

Not working:
ii armv7-eventlircd-osmc 1.4.5 armhf eventlircd for OSMC
ii armv7-lirc-osmc 0.9.4-3 armhf lirc for osmc
ii armv7-remote-osmc 1.2.3 armhf Remote support for OSMC, achieved with lirc and eventlircd

ii armv7-eventlircd-osmc 1.4.5 armhf eventlircd for OSMC
hi armv7-lirc-osmc 0.9.0-6 armhf lirc for osmc
ii armv7-remote-osmc 1.2.3 armhf Remote support for OSMC, achieved with lirc and eventlircd

@DBMandrake someone reported that the —uinput argument is no longer being parsed for either eventlircd or LIRC. As we use this stack as an input aggregator, this might be contributing.

This should now be solved.
Can you please try updating again and let us know if this works as expected?



Just updated to 0.9.4-5 and everything works again.
Thanks a lot for the fix and for your work on osmc in general :slight_smile:

Bye, Michael

It fixed it on mine as well.

Thanks for confirming chaps.

After long delay, I finally tested the IR fix for me an it seems to all work now. As this was on my “test” system, I’ll swap it into main use where it will get more testing but it all looks very good.

Thanks for all the hard work!