OSMC Can't see my Windows 10 SMB

Greetings, I had OSMC working with my Win 10 machine for some time, however I would often get ‘unable to update library’ errors, so I decided to scrap my shares and update both the server and OSMC.

I saw a post about using ‘fstab’ to configure shares that way, and this was the method I ended up using to get RetrOSMC to find my networked roms. That aspect of things works fine.

After modifying the fstab file, from SSH, I am able to view my network shared folders and see the contents of them, however back in OSMC, I’m unable to find or view them in the “add sources” option.

What am I missing?

(Currently away from home, so logs are not possible until tonight)

You will not be able to browse to them. You have to enter the path manually. A connected keyboard helps.

This is because browsing is no longer supported by Windows.

Ahh, good to know, thanks @grahamh .
Is this something that can be edited through SSH?

SSH is generally easier for me as I can remote-in and use my PC’s keyboard, rather than having to plug in a keyboard or peck-through with a gamepad.

As long as the “Network Discovery” service is running on the Windows system (and it is enabled by default), browsing of SMB shares works fine with Windows all the way up to Windows 10.

The trick is that the default in Windows 8 and up is to not allow non-authenticated users to browse shares. This can be changed, and again, browsing works.

Overall, though, the correct way to deal with it would be for OSMC to have a configuration that allowed the entry of a username/password that would be used to authenticate on the Windows network, and then browsing would work. Also, for those of us with Active Directory domains, allowing the OSMC box to join the domain would also solve the problem, once an “osmc” user is created in the domain.

1 Like

Another tid-bit of information that might be of use:
After setting up the fstab / CIFS information, and confirming that I can browse that content, I restarted and popped back into OSMC. From there I attempted to browse to /mnt where those fstab directories are mounted to, and it will not load. I get a ‘buffering’ log come up, but the directory will not list. I tried waiting over 5 minutes without luck.

Sorry to object, browsing is a feature of SMB1 which will be automatically be disabled by the latest Windows 10 upgrade if no smb1 client connects within 14 days after the update

While also smb1 was disabled in OSMC as default and would need to be enabled in settings if required

1 Like

This sounds strange. Can you check from command line if the mount worked? What does ls -lah /mnt/ gives you

I have confirmed SMB1 is enabled on my updated Win10 machine.

Regarding the command line @fzinken :

osmc@OSMC:/$ ls -lah /mnt
total 148K
drwxr-xr-x 5 root root 4.0K Dec 19 15:15 .
drwxr-xr-x 23 root root 4.0K Dec 15 18:57 …
drwxr-xr-x 2 root root 40K Oct 29 12:06 Family
drwxr-xr-x 2 root root 96K Dec 19 17:18 Movies
drwxr-xr-x 2 root root 4.0K Dec 19 14:42 TV

Those directories are populated with my media.

Well you then could force it in Kodi under Settings - Services - SMB Client - Max Protocol.
But to be honest I would leave that as it is and try to fix the fstab mount

Ok looks ok, but when you try to add them in Kodi as a source it just hangs? Try to upload debug logs after you try to add them as source

SMBv1 “browsing” isn’t the only way to browse for shares in a Windows network.

As I said, the “Network Discovery” service allows browsing of servers and shares. See https://support.microsoft.com/en-ph/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709 for more information. This also explains how to easily permanently re-enable SMBv1.

I went through this with Windows Server 2012 R2 (the server version of Windows 8.1), which has SMBv1 disabled by default out of the box. All modern Windows (7 and above) could browse the server just fine, but anything older needed SMBv1 enabled, and needed to have an authenticated user configured.

I have no idea how this affects Samba-based systems like Linux, but obviously it’s possible to browse even a pure SMBv2 or v3 network, since Windows does it, but I suspect it needs an authenticated user.

No one has been able to explain why I can see ny shares thru SSH, but OSMC can’t find anything.

Well I replied and ask for debug logs as the next step of investigation.

Also are you sure you add them as source and check then? While adding sources only folders will be shown no files!

Files are definitely there, I can view the whole library from within SSH, as I mentioned, OSMC is unable to see them.

I will try to follow up with logs when I can. Obviously busy with holidays for a few days.

I understand that, I just was asking where in OSMC you are not seeing them. When it is at the stage of “Add Source” it is normal that you don’t see the files as at that stage only folders are shown

Understood.
I will try with a manual entry in the Add Source section, and report back.

Ok, a bit of an update.

I didn’t have the option to manually enter a directory, it was greyed out. Weirdly enough, I enabled logging, restarted, and went back to Add Source. This time I still couldn’t see my network, but I was able to direct it to the /mnt/ path and add them there.

It all seemed to work fine. After dropping back to the menu, all of my TV shows appear to be there and workng fine.

My movies though, will not populate. I get a “couldn’t download information - could not connect to remote server” error. This is goofy, as my TV and Movies are on the same PC.

This error mentioned above, is what I was getting in the past, essentially preventing my media from updating.

Any suggestions?

EDIT: Logs

Search for “Kodi TMDB 401” I assume your tmdb addon might be outdated or there is any other issue with API key.

1 Like

@fzinken , Much Thanks!

That did it. I confirmed first by removing that as my scraper from my shares and my media appeared. I then went in and discovered my outdated add-ons. Updated TMDB, scraped again, and everything works. Thanks again for the assistance.