OSMC crashes after loading IPTV playlist on WIFI

I have been using OSMC to watch IPTV without issues for a while. My IPTV provider has recently updated their playlist. I’ve updated my Simple IPTV Player configuration with the new URL. Now when I start OSMC the “Loading Channels” progress bar appears. Once the last channel has loaded OSMC crashes.

The errors I see in the log are

11:51:32 62.195953 T:1740153888 ERROR: CCurlFile::FillBuffer - Failed: Couldn’t resolve host name(6)
11:51:32 62.196255 T:1740153888 ERROR: CCurlFile::Open failed with code 0 for http://URL-Removed
11:51:32 62.196426 T:1740153888 ERROR: Open - failed to open source http://URL-Removed
11:51:32 62.196732 T:1740153888 ERROR: AddOnLog: PVR IPTV Simple Client: Unable to load playlist file ‘http://URL-Removed’: file is missing or empty.

I can ping the domain hosting the playlist and I can download it using wget from the Pi.

I install Kodi on my windows laptop and tried the new playlist and it works fine.

in IPTV Simple configuration you point to playlist using a link?
if so, download the playlist locally (to OSMC, say home folder) and use it locally in config.

see if this helps.

1 Like

Thanks Grey. That half works. I can get the channels but the EPG and logos aren’t working. I guess because they also are not loading when the system come up.

So it would still be great if anybody had any suggestions how to fix this? Maybe the WiFi card isn’t coming up fast enough? Although it worked fine for the older playlist. It’s got me stumped.

well, in same IPTV Simple config you show where to take the EPG from.
now, if it was working with old playlist and not with the new one (and the settings to EPG is still there) then only one explanation - in new playlist channels changed their names…

Hi Grey,
the EPG is also new. And works fine in Kodi on my Windows box. So I know the playlists, EPGs, logos etc. are working. It’s an issue unique to my OSMC installation.

okay. last resort (from me) is as we are on linux, see the uppercase/lowercase in the names. as for linux, afaik, Test and test are different.

As far as I know URLS are case insensitive. Also the URL contains all lowercase letters. However I will try it after work on my ubuntu laptop. Thanks!

no, i meant now there is a possibility that in your new playlist the channels are not named the same as expected in the epg file.

I tested it on my home pi. Same build and same hardware. The only difference is the Pi at home is wired and on a different network.

Same to me. IPTV via WiFi is hard work for the RPI. Remote is not working correctly. After changing to wired connection everything will be allright. This behavior is since august realease.