OSMC crashes if stop button pressed at end of playback

I am using OSMC-Kodi to play videos downloaded automatically on an Ubuntu 20 server.
The videos are accessed by Kodi as video files via a samba share on the Ubuntu server. No need for any “library” or similar since they are one-off videos only watched once.
The failure I want to report can be reproduced 100%.

I have set up my Kodi to start playback of the next video in a folder when the watched video ends.
If I am watching the video and I notice that it is about to end while I do not want to see the following video right now I press the square button on my TV remote. This is transferred to Kodi via HDMI CEC.

At this moment there is a pause of a second or two, then a blue screen appears with a sad emoji centered.
And OSMC reboots!!!

As I said it is 100% reproducible, happens every time I use the square stop key at the time the watched video is ending.

I believe this is an error/bug in OSMC.
At the moment I am using:
OSMC 2021.08-1
Kodi 19.1
It has become rather annoying since I pretty often want to wait a while before watching the next video…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

OK, will do tomorrow morning.

Test now done. Log files here
I noted that the first and second reboot acted differently (took different times).
When I tried to access MyOSMC after I had captured the pronblem it first said:
“MyOSMC service is unavailable”
But then after a second try I managed to get it running so I could upload the log.
And I did not switch off logging until I had succeeded in uploading the logs, is this the correct way?

I noted that openvpn is mentioned a lot in the logs, this is caused by me having installed openvpn on this device a long time ago but it is no longer in use.
I have now disabled the openvpn service and the problem is still present:
When I hit the square stop button at the time a video ends and the next will be auto-started OSMC fully crashes and reboots.

Any idea why the crash is happening?


How is the usb drive (/mnt/mediadrive), powered?

Thanks Tom.

Adjust display refresh rate: Off

Have you tried with this set to On Start/stop as we normally recommend?

It is connected by a 20 cm long USB2 cable. It supplies power to the disk.

Note that the videos are not on this drive when I tested the problem!
The watched videos are on a samba share from an Ubuntu file server.

I have not seen this recommended anywhere, so I have not done that. Can you suggest how it is to be done?

Regarding your video issue, check some settings you find at

GUI Settings->Player->Video

There activateAdjust Display Refresh Rate” and deactivateSync Playback to Display”. The latter prevents audio pass-through modes in general.

Also, I saw your comment about the drive on /mnt/mediadrive being powered via USB. This may be causing a power issue, even if you are not playing any video from that drive at the time. If changing the Refresh Rate doesn’t help, try without the mediadrive connected.

1 Like

I am at a loss here…
The videos play just fine both from the mediadrive and from the smb share, this is NOT the issue.

The report is about a very localized point in time, when I push the STOP button on the TV remote just as Kodi is closing one video in order to start playing the next, then OSMC (not Kodi) crashes and reboots!
What in any way could the Playback to Display setting have anything to do with this?
If I do NOT push the STOP button then the next video starts playing just fine so if I wait a few seconds longer all is well and I can then use the STOP button to end the viewing.


As are we. We are suggesting things to test and try to diagnose the issue.

As suggested testing with the mediadrive disconnected may help as I believe kodi 19 draws more power than previous releases; which may explain the current issue. Also its recommended that external drives are externally powered; I suggest using a powered USB hub.

Setting this to to start/stop as suggested may resolve the issue, if not the viewing experience should be better.

Regards Tom.

It would be helpful if you could tell me where I can change this Start/Stop setting. Is it by editing the keymap file or the main configuration file?
By your wording it seems to be a setting tied to the actual button press, right?

Settings>Player>Videos>Adjust display refresh rate> On start/stop

Thanks, I did that now and the Sync playback to display was already deactivated.
So I have made two quick tests and now the crash did not happen!
Will keep my eyes open for this going forward.

One thought more:
Since this device is a Raspberry 2B, maybe it is not quite up to the task?
Can I just move the SD-card over to an RPi3B or an RPi4B and OSMC will run or do I have to make a new installation from scratch?
It will obviously receive a new IP address from the router because of the new MAC address, but apart from that would it work?
The USB disk is connected via its UUID in /etc/fstab like this (on one line obviously):
UUID=EE78237678233D29 /mnt/mediadrive ntfs defaults,auto,dmask=000,fmask=111,uid=1000,gid=1000,rw,nofail 0 0
so I think that the disk mount will remain and I believe that the RPi4B has way more power available on the USB connectors than RPi2B has, right?

Pi3 yes, Pi4 no

I did give you that information in my previous post.

Maybe in the future you will learn that when we make a suggestion that you should try it before arguing with us.


And don’t forget! Since you’ve been an active forum member for over six years, providing logs immediately when making a support request instead of waiting on us to prompt you to provide them saves time for all parties! :nerd_face:


I just want to report back that the problem remains.
Right now I am just finished watching one installment of a downloaded video and I hit the stop button at the critical moment.
Sure enough it crashed again, sad emoji and all.
No logs are available since I switched off debug logging after the previous report.
Just mark this issue as “not found and solved”.
I will try to find a Raspberry Pi3B in my cupboards so I can replace the RPi2B, which is doing this, using the same SDcard (or a clone thereof).