OSMC crashes on playing audio over network

I am new to OSMC/KODI. I recently install OSMC on raspberry pi 2 and I plan use it as my access center to play local and internet media to TV. I am planning on purchasing an external HDD and connect it to the USB port of my router permanently as a media server and access it from all my devices including raspberry pi 2. Before I purchase HDD, I am trying to test the functionality of my setup.

Issue: I cannot play audio files stored in the USB drives via music option on OSMC. I can see the file list and as soon as I select any music file, OSMC crashes with sad face and restarts. I have tried FLAC and MP3 files on separate USB drives, separate ports on the router, with the same results.

  • I can access and play video files fine via OSMC from the same USB drives connected the same way on the router.
  • I can access and play the same music files from my computer wirelessly via smb (mac).
  • I can play same music files if I connect the USB drives to raspberry Pi directly.

So, its only the issue with playing audio files over the network.

Raspberry Pi 2
Ethernet straight to router
Output to Yamaha Receiver via HDMI, then to TV from the receiver.
WD n750 router with USB ports.
USB flash drives on router. Tried both NTFS and ExFAT formats.

FLAC and mp3 files in flash drives.

OSMC latest version
Factory Software on router.

I am a linux noob so, I have no idea how to access logs, so if someone could point me in the right direction on how to access it, I will pull up the log files and post it here. Any help is greatly appreciated.


1 Like

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to provide logs.

Thanks, I did generate a log following the advice on the provided link.
Towards the end of the log, I can see the errors generated for the files but I am not savvy enough to know what to do next.

You need to either fix MySQL settings in advancedsettings.xml or delete them completely. Kodi is looking for a MySQL db that is impossible for it to find/use since you only have it half configured.

1 Like

Thank you for pointing me in the right direction. I will do some research on it and update with any progress or pitfalls.

Should probably delete /home/osmc/.kodi/userdata/advancedsettings.xml then reboot. If you are actually using a MySql database and it is shared somewhere then you will need to rewrite advancedsettings.xml

Finally had some free time to tinker. Still the same issue.
Things I have tried:

  • Tried removing the line mysql from advancedsettings.xml. Same issue.
  • Deleted the source.xml and advancedsettings.xml. Same issue.
  • Copied a single mp3 file to the flash drive containing a video file. Same issue. Video file from the same drive plays.
  • Same USB drive connected directly to raspberry pi plays audio and video without any problem.


PS: I am adding the source as the IP address of the router using SMB and then selecting the drive connected to the USB port of the router.

i have exactly the same problem.
if i try to play an ogg music file located on my NAS OSMC crashes.
if i try to play a mp3 from that NAS the playback will stop after 1-4s and sometimes kodi dies too.
However if i try to play the same file from an smb share on my PC everything works fine.

I don’t realy understand why this is happening because it makes no sense whatsoever. I used SMB shares in both cases.

My NAS and it’s SMB shares work fine when i use openelec

Still the same issue, even after the new update 4.4.3-3