OSMC crashing after start up / CPU-KODI over 100%

I’ve been digging around but this is proving a little beyond me. I’m yet to figure out the culprit.

I’ve a RPI4B+ in an ArgonOne M2 case running what I think is the latest version of OSMC (2023.01-1). Very soon after its finished booting, the PI will freeze briefly, then throw up the unhappy face page and reboot. After that, everything is generally fine. I’ve noticed that on the first startup CPU-KODI is sitting at over 100% but once it has crashed/rebooted it’s sitting down at 15-20%. No idea if that is relevant.

Here are the debug logs which include attempts from last night as well as today. Probably best to look at time stamps beginning around 1437.

I’ve also noticed that the PI will often crash during the credits of Disney+ shows. But only part way into the credits, regardless of the overall length of the show. Again, weird and I’m struggling to diagnose.

Any help / pointers will be appreciated.

Specific question:

  1. Is it possible to completely clear all past log files so that I get a “clean slate”. Might help in spotting what is causing the issue.

Does it do it if you boot without the hard drive attached?

Yep. Here is what I tried today:

  1. HDD unplugged; USB DAC off → started fine
  2. Rebooted → also fine
  3. (May have repeated a few more times, I didn’t count exactly)
  4. Turned USB DAC on, then rebooted → crashed
  5. Turned USB DAC off, then rebooted → crashed
  6. Rebooted → crashed.

Here is the log

Bah. Forgot to turn on debugging logs. My bad.

Corrected logs here. Look for timestamps begining around 02-April at 1306. Seems to be related to USB DAC and audio output being set to accordingly (i.e. not set to vc4-hdmi-0).

Have you tried a different PSU or running the USB devices through a powered USB hub?

1 Like

The USB DAC has it’s own power supply. In my trials earlier the portable HDD was disconnected. So the only things connected to the Pi were ethernet, power, USB (to the DAC), HDMI to TV.