OSMC difficulty setting up WiFi

I have been using the connmanctl to try and connect to my wifi network, but I have been having issues.

connmanctl> technologies
Name = WiFi
Type = wifi
Powered = True
Connected = False
Tethering = False
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False

I think this is telling me that my WiFi dongle is recognized (it’s an Adafruit model 814 with a RTl8192/8188CUS Chipset). The ethernet is what my SSH connection for the terminal goes through.

connmanctl> scan wifi
Error /net/connman/technology/wifi: Device or resource busy

This is the error I always get with when scanning. I can disable the wifi and then re-enable it and I still get this error.

connmanctl> disable wifi
Disabled wifi
connmanctl> enable wifi
Enabled wifi
connmanctl> scan wifi
Error /net/connman/technology/wifi: Device or resource busy

Using the services command shows the services I have available and I think the lowercase “a” denotes that it is set to autoconnect to the wireless network I want to connect to. I was wondering if autoconnect is why the device is busy, so I tried to disable the autoconnect and also to connect or disconnect to the wireless network.

connmanctl> connect wifi__managed_psk
Error /net/connman/service/wifi
_managed_psk: In progress
connmanctl> disconnect wifi
Disconnected wifi
connmanctl> connect wifi
Error /net/connman/service/wifi
_managed_psk: In progress
connmanctl> config wifi
_managed_psk --autoconnect no
Error wifi
__managed_psk: Invalid service

I am currently at a loss for how I can connect to my wireless network. (My hardware worked fine with RaspBMC.)

Note: I used post Enable wifi under GUI to do everything I did in connmanctl

I’m guessing that you have an Ethernet cable connected as well? Connmanctl is currently configured to only use WiFi if Ethernet is not connected.

1 Like

Thank you for your help. That definitely explains why I had that issue.

I was using the Connmanctl (and the wired network SSH login) because in the OSMC GUI whenever I try to connect to my preferred wireless network (after entering the password when it tries to connect to the network) it hangs on the rotating dots and I have to do a hard power-off to get out of it.

Should I create a new topic with log files for this error?

You’ve attempted with the GUI while Ethernet is disconnected?

So one can not connect to wifi when connected via ethernet? I also have no keyboard, so i first connect via cabled ssh. When i try to connect via gui, osmc hangs with a :frowning:-emoticon and reboots. After rebooting my system wifi connects. Instead directly connecting to wifi with connmanctl works for me.

Sorry for the delay. Yes, I attempted what you have suggested. I also attempted many other combinations of things that I thought should have worked.

What finally worked is that I re-installed the software on the MicroSD card. After multiple re-installations to replicate and verify the issue, I think I have figured out what went wrong.

I am using the OSMC installer EXE for Windows. Apparently, when you misspell the WiFi password in the installation process (on your Windows machine), OSMC can’t recover from this mistake and you will never be able to get the WiFi to work, even if you re-enter the right password in OSMC when trying to connect to the network. I am not sure of the exact mechanics of why, I have only verified as best I can that this is the initial cause of the issue and it cannot be overcome later.

i am trying your suggestion right now. You might be my savior!