OSMC does not boot, new install (Pi Zero)

Hi there,

I’m new to Raspberry Pi and I’m trying to install OSMC on my Pi Zero. Installation seems to work fine and pretty quickly. However, after installation the Pi shows the OSMC logo and freezes there. I’ve tried restarting and formatting my SD card again but the same problem occurs.

Any suggestions?


Check your power supply and/or try another SD card.

Thanks for the fast reply. I already tried multiple power supplies. But I will try another SD card.

Problem turned out to be the SD card. I tried a Samsung Evo card instead of a cheap unbrandend one. Problem was solved. Thanks!

I’ve had the same problem about a year ago, I also changed my card to Samsung and no problems since then. Enjoy.

1 Like

I have used several different brands of cards… cannot get it to come back from the BSOD after OSMC installation is complete…

@Kodypython: Please do not keep posting in other threads. You’ve started your own.

I was not trying to double post… just trying to answer others…